summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Castro2017-10-25 21:27:23 -0500
committerGustavo Castro2017-10-25 21:27:23 -0500
commit07c87b0230c312661eb4571ac9040b6bb59d3301 (patch)
treee8806b20a1eacccd3d141f18c4ed82d450a4943d
downloadaur-07c87b0230c312661eb4571ac9040b6bb59d3301.tar.gz
Initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d70c3eac120
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qtcreator-terminal-plugin-git
+ pkgdesc = A konsole-like terminal plugin for Qt Creator
+ pkgver = 2119fe7
+ pkgrel = 1
+ url = https://github.com/manyoso/qt-creator-terminalplugin
+ arch = i686
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = LGPL2.1
+ makedepends = git
+ makedepends = qtcreator-src
+ depends = qtcreator
+ depends = qtermwidget
+ provides = qtcreator-terminal-plugin
+ conflicts = qtcreator-terminal-plugin
+ source = qtcreator-terminal-plugin-git::git://github.com/manyoso/qt-creator-terminalplugin.git
+ md5sums = SKIP
+
+pkgname = qtcreator-terminal-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e884aa56e15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gustavo Castro < gustawho [ at ] openmailbox [ dot ] org >
+
+_pkgname=qt-creator-terminalplugin
+pkgname=qtcreator-terminal-plugin-git
+pkgver=2119fe7
+pkgrel=1
+pkgdesc="A konsole-like terminal plugin for Qt Creator"
+groups=('qt' 'qt5')
+arch=('i686' 'x86_64')
+url='https://github.com/manyoso/qt-creator-terminalplugin'
+license=('LGPL2.1')
+depends=('qtcreator' 'qtermwidget')
+makedepends=('git' 'qtcreator-src')
+provides=('qtcreator-terminal-plugin')
+conflicts=('qtcreator-terminal-plugin')
+source=("$pkgname::git://github.com/manyoso/qt-creator-terminalplugin.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $pkgname
+ # TODO: QTC_BUILD=/usr
+ QTC_SOURCE=/usr/src/qtcreator QTC_BUILD=build/usr qmake LIBS+="-L/usr/lib/qtcreator -L/usr/lib/qtcreator/plugins"
+ make
+}
+
+package() {
+ cd $pkgname
+ cp -r build/* ${pkgdir}
+}