summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbigail G2021-01-24 15:14:30 -0500
committerAbigail G2021-01-24 15:14:30 -0500
commitc3c46af9cde0072c2f67baf2396fb65562753391 (patch)
tree1a41dea07b551175797f6c3817ca5adff83bc2e4
parent352f4b70b1f6627da38c9e32819c3ac598e76d3c (diff)
downloadaur-c3c46af9cde0072c2f67baf2396fb65562753391.tar.gz
upgpkg: qtel 19.09.1-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1af050fb2ebb..841e65f0b9ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,9 @@
pkgbase = qtel
pkgdesc = Graphical Userinteface for Echolink written in QT
pkgver = 19.09.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.github.com/sm0svx/svxlink/
- arch = i686
arch = x86_64
- arch = armv5h
- arch = armv6h
- arch = armv7h
license = GPL
makedepends = cmake
depends = alsa-utils
@@ -19,7 +15,7 @@ pkgbase = qtel
depends = tcl
depends = speex
depends = opus
- depends = qt4
+ depends = qt5-tools
conflicts = svxlink
source = https://github.com/sm0svx/svxlink/archive/19.09.1.tar.gz
sha256sums = 5e5cbc3501fa6c6ec68334f8217ef93f5dc879d4d0e41e6f71378fd67d69f6a2
diff --git a/PKGBUILD b/PKGBUILD
index 1be49e35e5af..4b5670fd62af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributer: Carsten Feuls (DL1CAF) 'Der Techniker' <dl1caf@vfdb.org>
# Contributer: Amateurfunk Station der Hochschule Niederrhein (DF0FN) <df0fn@hs-niederrhein.de>
-pkgname=('qtel')
-_pkgname=('svxlink')
-pkgver="19.09.1"
-pkgrel=1
-arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+pkgname=qtel
+_pkgname=svxlink
+pkgver=19.09.1
+pkgrel=2
+arch=('x86_64')
url="http://www.github.com/sm0svx/svxlink/"
license=('GPL')
source=("https://github.com/sm0svx/${_pkgname}/archive/${pkgver}.tar.gz")
conflicts=("svxlink")
sha256sums=('5e5cbc3501fa6c6ec68334f8217ef93f5dc879d4d0e41e6f71378fd67d69f6a2')
-depends=('alsa-utils' 'alsa-lib' 'libsigc++' 'gsm' 'libgcrypt' 'popt' 'tcl' 'speex' 'opus' 'qt4')
+depends=('alsa-utils' 'alsa-lib' 'libsigc++' 'gsm' 'libgcrypt' 'popt' 'tcl' 'speex' 'opus' 'qt5-tools')
makedepends=('cmake')
pkgdesc="Graphical Userinteface for Echolink written in QT"
@@ -27,13 +27,12 @@ build(){
package(){
make -C ${srcdir}/${_pkgname}-${pkgver}/src/build DESTDIR="${pkgdir}" install
- rm ${pkgdir}/usr/bin/{remotetrx,siglevdetcal,svxlink}
+ rm ${pkgdir}/usr/bin/{remotetrx,siglevdetcal,svx*,devcal}
rm -rf ${pkgdir}/usr/include
rm -f ${pkgdir}/usr/lib/libasynccpp.so*
- rm -f ${pkgdir}/usr/lib64/libasynccpp.so*
- rm -rf ${pkgdir}/usr/lib/svxlink
- rm -rf ${pkgdir}/usr/lib64/svxlink
- rm -rf ${pkgdir}/usr/share/{doc,man,svxlink}
+ rm -rf ${pkgdir}/usr/lib/svxlink
+ rm -rf ${pkgdir}/usr/share/doc/{svxlink,echolib}
+ rm -rf ${pkgdir}/usr/share/svxlink
rm -r ${pkgdir}/var
rm -r ${pkgdir}/etc
}