summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2024-03-12 15:51:12 -0700
committerMichael Hansen2024-03-12 15:51:12 -0700
commit0660a5aa89e12f03a4e1410d04b22ddb9602e28e (patch)
tree87b78b9a71f338e10a26b13a5a391109d0ebe784
parent1b1958b9bc80493fb4885160450470568e4f754e (diff)
downloadaur-0660a5aa89e12f03a4e1410d04b22ddb9602e28e.tar.gz
Update to 1.11
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--force_qt5.patch12
3 files changed, 14 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceca4e9ceb73..d58494f47027 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = qtextpad
- pkgdesc = Lightweight cross-platform text editor using KF5's syntax highlighting repository.
- pkgver = 1.10
- pkgrel = 2
+ pkgdesc = Lightweight cross-platform text editor using KF6's syntax highlighting repository.
+ pkgver = 1.11
+ pkgrel = 1
url = https://github.com/zrax/qtextpad
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
- depends = syntax-highlighting5
- source = qtextpad-1.10.tar.gz::https://github.com/zrax/qtextpad/archive/1.10.tar.gz
- source = force_qt5.patch
- sha256sums = 31173a2f19e7ad6db1f0a610f449e19a27e4399620e7f9480c249e30d3fd55ec
- sha256sums = f4c20348814fef477bace4cd575aab0e90373635fbb7720f804ab8c5bac73ed0
+ depends = syntax-highlighting
+ source = qtextpad-1.11.tar.gz::https://github.com/zrax/qtextpad/archive/1.11.tar.gz
+ sha256sums = 8257ba89f954811808d7a9b951a5456e201f907df3dbc4067d2584cfcabd168f
pkgname = qtextpad
diff --git a/PKGBUILD b/PKGBUILD
index 94d3301534f8..353a993fb78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: Michael Hansen <zrax0111 gmail com>
pkgname=qtextpad
-pkgdesc="Lightweight cross-platform text editor using KF5's syntax highlighting repository."
-pkgver=1.10
-pkgrel=2
+pkgdesc="Lightweight cross-platform text editor using KF6's syntax highlighting repository."
+pkgver=1.11
+pkgrel=1
arch=('i686' 'x86_64')
url='https://github.com/zrax/qtextpad'
license=('GPL3')
-depends=('syntax-highlighting5')
+depends=('syntax-highlighting')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- force_qt5.patch)
-sha256sums=('31173a2f19e7ad6db1f0a610f449e19a27e4399620e7f9480c249e30d3fd55ec'
- 'f4c20348814fef477bace4cd575aab0e90373635fbb7720f804ab8c5bac73ed0')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # KSyntaxHighlighting only supports Qt5 in Arch for now...
- patch -p1 -i "${srcdir}/force_qt5.patch"
-}
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('8257ba89f954811808d7a9b951a5456e201f907df3dbc4067d2584cfcabd168f')
build() {
mkdir -p "${srcdir}/build"
cd "${srcdir}/build"
- cmake -DCMAKE_BUILD_TYPE=Release \
+ cmake -DQT_VERSION_MAJOR=6 \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
"${srcdir}/${pkgname}-${pkgver}"
diff --git a/force_qt5.patch b/force_qt5.patch
deleted file mode 100644
index 17b8f9fd155a..000000000000
--- a/force_qt5.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2023-05-26 14:14:14.718672640 -0700
-+++ b/CMakeLists.txt 2023-05-26 14:14:26.132005819 -0700
-@@ -22,7 +22,7 @@ set(CMAKE_CXX_STANDARD 11)
-
- include(FeatureSummary)
-
--find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
-+find_package(QT NAMES Qt5 REQUIRED COMPONENTS Core)
- find_package(Qt${QT_VERSION_MAJOR} 5.10 REQUIRED COMPONENTS
- Core Widgets PrintSupport Network)
- if(Qt5_FOUND AND NOT TARGET Qt::Core)