summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2023-05-26 14:19:43 -0700
committerMichael Hansen2023-05-26 14:19:43 -0700
commitf40bc37444f7a721fe28598471c4767091157d74 (patch)
treec2146c4a82a7bba4e9d1295bc71dfd80bbac0baa
parent8cabacc51e334a696427d48781b592209e1ed0a3 (diff)
downloadaur-f40bc37444f7a721fe28598471c4767091157d74.tar.gz
Update to 1.10
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--force_qt5.patch8
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5480cb30702..f3cc3e56459a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtextpad
pkgdesc = Lightweight cross-platform text editor using KF5's syntax highlighting repository.
- pkgver = 1.9.1
+ pkgver = 1.10
pkgrel = 1
url = https://github.com/zrax/qtextpad
arch = i686
@@ -8,9 +8,9 @@ pkgbase = qtextpad
license = GPL3
makedepends = cmake
depends = syntax-highlighting
- source = qtextpad-1.9.1.tar.gz::https://github.com/zrax/qtextpad/archive/1.9.1.tar.gz
+ source = qtextpad-1.10.tar.gz::https://github.com/zrax/qtextpad/archive/1.10.tar.gz
source = force_qt5.patch
- sha256sums = 1f3f4728b26cd5066fb97db1ed671d09a81ca85ee86d3bfa2f550e9d7b1f3cfe
- sha256sums = e0e837bf92fcc23d6c93b70e25eaed35e88a4c3dbe87b848e1a13dcfcf8f9855
+ sha256sums = 31173a2f19e7ad6db1f0a610f449e19a27e4399620e7f9480c249e30d3fd55ec
+ sha256sums = f4c20348814fef477bace4cd575aab0e90373635fbb7720f804ab8c5bac73ed0
pkgname = qtextpad
diff --git a/PKGBUILD b/PKGBUILD
index 4aabf267b638..d84546229cb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qtextpad
pkgdesc="Lightweight cross-platform text editor using KF5's syntax highlighting repository."
-pkgver=1.9.1
+pkgver=1.10
pkgrel=1
arch=('i686' 'x86_64')
url='https://github.com/zrax/qtextpad'
@@ -11,8 +11,8 @@ depends=('syntax-highlighting')
makedepends=('cmake')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
force_qt5.patch)
-sha256sums=('1f3f4728b26cd5066fb97db1ed671d09a81ca85ee86d3bfa2f550e9d7b1f3cfe'
- 'e0e837bf92fcc23d6c93b70e25eaed35e88a4c3dbe87b848e1a13dcfcf8f9855')
+sha256sums=('31173a2f19e7ad6db1f0a610f449e19a27e4399620e7f9480c249e30d3fd55ec'
+ 'f4c20348814fef477bace4cd575aab0e90373635fbb7720f804ab8c5bac73ed0')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/force_qt5.patch b/force_qt5.patch
index babf63bebfca..17b8f9fd155a 100644
--- a/force_qt5.patch
+++ b/force_qt5.patch
@@ -1,12 +1,12 @@
diff -rupN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2022-06-14 12:18:25.506502296 -0700
-+++ b/CMakeLists.txt 2022-06-14 12:18:38.946502190 -0700
+--- a/CMakeLists.txt 2023-05-26 14:14:14.718672640 -0700
++++ b/CMakeLists.txt 2023-05-26 14:14:26.132005819 -0700
@@ -22,7 +22,7 @@ set(CMAKE_CXX_STANDARD 11)
include(FeatureSummary)
-find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
+find_package(QT NAMES Qt5 REQUIRED COMPONENTS Core)
- find_package(Qt${QT_VERSION_MAJOR} 5.6 REQUIRED COMPONENTS
+ find_package(Qt${QT_VERSION_MAJOR} 5.10 REQUIRED COMPONENTS
Core Widgets PrintSupport Network)
- if(QT_VERSION_MAJOR GREATER 5)
+ if(Qt5_FOUND AND NOT TARGET Qt::Core)