summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsclapion2015-06-16 13:40:33 +0200
committerEsclapion2015-06-16 13:40:33 +0200
commit26de1d560055eced03af85761ca92d66396e7ff9 (patch)
treee51514e07aabb18907cb6ff7775f97f8bc616ea8
downloadaur-qtfind.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--qtfind_1.2.tar.gzbin0 -> 58958 bytes
4 files changed, 55 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ff924e50b7ba
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = qtfind
+ pkgdesc = qt5 search tool for pcmanfm-qt
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://forum.manjaro.org/index.php?topic=16371.0
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = qt5-base
+ source = qtfind_1.2.tar.gz
+
+pkgname = qtfind
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..805898646482
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = qtfind
+ pkgdesc = qt5 search tool for pcmanfm-qt
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://forum.manjaro.org/index.php?topic=16371.0
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = qt5-base
+ source = qtfind_1.2.tar.gz
+ md5sums = 84bf3c7ae8ae2f19c494257dfc92baef
+
+pkgname = qtfind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..714aa2fd1d32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: esclapion <esclapion[at]gmail[dot]com>
+
+pkgname=qtfind
+pkgver=1.2
+pkgrel=1
+pkgdesc="qt5 search tool for pcmanfm-qt"
+url="https://forum.manjaro.org/index.php?topic=16371.0"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=(qt5-base)
+optdepends=()
+source=("${pkgname}_$pkgver.tar.gz")
+md5sums=('84bf3c7ae8ae2f19c494257dfc92baef')
+
+build() {
+ cd $srcdir/${pkgname}_$pkgver
+ qmake-qt5 QT+=core QT+=widgets
+ make
+}
+
+package() {
+ cd $srcdir/${pkgname}_$pkgver
+ install -D ${pkgname} $pkgdir/usr/bin/$pkgname
+ install -D ${pkgname}.png $pkgdir/usr/share/pixmaps/${pkgname}.png
+ install -D ${pkgname}.desktop $pkgdir/usr/share/file-manager/actions/${pkgname}.desktop
+ mkdir -p $pkgdir/usr/lib/${pkgname}_i18n
+ install -D ${pkgname}_i18n/*.qm $pkgdir/usr/lib/${pkgname}_i18n
+}
diff --git a/qtfind_1.2.tar.gz b/qtfind_1.2.tar.gz
new file mode 100644
index 000000000000..29367ad167c0
--- /dev/null
+++ b/qtfind_1.2.tar.gz
Binary files differ