summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-08-02 17:49:38 +0200
committerhaawda2020-08-02 17:49:38 +0200
commit6441e63d56345705972267e4c280ca131a8b9f7a (patch)
treed1f05c12c3fff746119699d0771bb4b0561f8856
parent81ebca16f6cf3f37e866d3e1be63a8f20b553531 (diff)
downloadaur-6441e63d56345705972267e4c280ca131a8b9f7a.tar.gz
add patch to build with qt 5.15+
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--qt-5.15+gentoo.patch22
3 files changed, 34 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57580546d178..bd7d608a5247 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtfm
pkgdesc = A lightweight file manager
pkgver = 6.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rodlie/qtfm/releases
arch = i686
arch = x86_64
@@ -10,7 +10,9 @@ pkgbase = qtfm
depends = desktop-file-utils
depends = hicolor-icon-theme
source = qtfm-6.2.0.tar.gz::https://github.com/rodlie/qtfm/archive/6.2.0.tar.gz
+ source = qt-5.15+gentoo.patch
sha256sums = 58c6af502b606e63f96e8aec96b65ca9125be18ecdd5e4680ccaf50e9c40b064
+ sha256sums = 143a664ccd9b677924f6168d7d358201b8693a03f3a0c76efe348f7b39489b99
pkgname = qtfm
diff --git a/PKGBUILD b/PKGBUILD
index 662b2152965a..cb79872471ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,20 @@
pkgname=qtfm
pkgver=6.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A lightweight file manager"
arch=('i686' 'x86_64')
url="https://github.com/rodlie/qtfm/releases"
license=('GPL')
depends=('qt5-base' 'desktop-file-utils' 'hicolor-icon-theme')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rodlie/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('58c6af502b606e63f96e8aec96b65ca9125be18ecdd5e4680ccaf50e9c40b064')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rodlie/$pkgname/archive/$pkgver.tar.gz" qt-5.15+gentoo.patch)
+sha256sums=('58c6af502b606e63f96e8aec96b65ca9125be18ecdd5e4680ccaf50e9c40b064'
+ '143a664ccd9b677924f6168d7d358201b8693a03f3a0c76efe348f7b39489b99')
+
+prepare() {
+ cd $pkgname-${pkgver//_/-}
+ patch -Np1 < "$srcdir"/qt-5.15+gentoo.patch
+}
build() {
cd $pkgname-${pkgver//_/-}
diff --git a/qt-5.15+gentoo.patch b/qt-5.15+gentoo.patch
new file mode 100644
index 000000000000..9e9a0e58c8d7
--- /dev/null
+++ b/qt-5.15+gentoo.patch
@@ -0,0 +1,22 @@
+diff -Naur qtfm-6.2.0.orig/libfm/iconlist.cpp qtfm-6.2.0.new/libfm/iconlist.cpp
+--- qtfm-6.2.0.orig/libfm/iconlist.cpp 2019-06-04 07:47:00.000000000 +0200
++++ qtfm-6.2.0.new/libfm/iconlist.cpp 2020-08-02 17:47:04.899432194 +0200
+@@ -1,5 +1,7 @@
+ #include "iconlist.h"
+
++#include <QpainterPath>
++
+ QSize IconListDelegate::sizeHint(const QStyleOptionViewItem &option,
+ const QModelIndex &index) const
+ {
+diff -Naur qtfm-6.2.0.orig/libfm/iconview.cpp qtfm-6.2.0.new/libfm/iconview.cpp
+--- qtfm-6.2.0.orig/libfm/iconview.cpp 2019-06-04 07:47:00.000000000 +0200
++++ qtfm-6.2.0.new/libfm/iconview.cpp 2020-08-02 17:46:53.629482772 +0200
+@@ -1,5 +1,7 @@
+ #include "iconview.h"
+
++#include <QPainterPath>
++
+ bool IconViewDelegate::eventFilter(QObject *object,
+ QEvent *event)
+ {