summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-10-28 22:12:26 +0200
committerhaawda2017-10-28 22:12:26 +0200
commitb7f70863cb5d784a84227ca91fe918812a1c819e (patch)
treee5c230500e8b9fd989d0a4345710eb47ee41effb
parentf04fefa02a0e36c3bddae440914c8f3fe7b916aa (diff)
downloadaur-b7f70863cb5d784a84227ca91fe918812a1c819e.tar.gz
adopt and make it build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--make_it_build_fixes.patch12
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5906dcba2f24..33488c70bd78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 21 11:30:55 UTC 2017
+# Sat Oct 28 20:12:07 UTC 2017
pkgbase = qtfm
pkgdesc = A lightweight file manager
pkgver = 5.9
- pkgrel = 3
+ pkgrel = 4
url = http://qt-apps.org/content/show.php/QtFM?content=158787
changelog = qtfm.changelog
arch = i686
@@ -13,7 +13,9 @@ pkgbase = qtfm
depends = qt5-base
depends = desktop-file-utils
source = https://dl.opendesktop.org/api/files/download/id/1466643163/158787-qtfm.zip
+ source = make_it_build_fixes.patch
sha256sums = 07ffd61dd5d4aa7c16f1c544804517b621e3ef1a30eeda97c087219a3cb35128
+ sha256sums = 1a77d7699e60be1af8ba0aef779894599bd46f5bc3545347d3989154d0576642
pkgname = qtfm
diff --git a/PKGBUILD b/PKGBUILD
index 85b67225b9a9..0769f1c0aa3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,35 @@
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Brad Fanella <bradfanella@archlinux.us>
# Contributor: Wittfella <wittfella@wittfella.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=qtfm
pkgver=5.9
-pkgrel=3
+pkgrel=4
pkgdesc="A lightweight file manager"
arch=('i686' 'x86_64')
url="http://qt-apps.org/content/show.php/QtFM?content=158787"
license=('GPL')
depends=('file' 'qt5-base' 'desktop-file-utils')
changelog=$pkgname.changelog
-source=(https://dl.opendesktop.org/api/files/download/id/1466643163/158787-$pkgname.zip)
-sha256sums=('07ffd61dd5d4aa7c16f1c544804517b621e3ef1a30eeda97c087219a3cb35128')
+source=(https://dl.opendesktop.org/api/files/download/id/1466643163/158787-$pkgname.zip make_it_build_fixes.patch )
+sha256sums=('07ffd61dd5d4aa7c16f1c544804517b621e3ef1a30eeda97c087219a3cb35128'
+ '1a77d7699e60be1af8ba0aef779894599bd46f5bc3545347d3989154d0576642')
+
+prepare() {
+ cd $pkgname
+ patch -Np1 < "$srcdir"/make_it_build_fixes.patch
+}
build() {
- cd "${srcdir}"/$pkgname
+ cd $pkgname
qmake
make
}
package() {
- cd "${srcdir}"/$pkgname
+ cd $pkgname
make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/make_it_build_fixes.patch b/make_it_build_fixes.patch
new file mode 100644
index 000000000000..5adbf6f4664e
--- /dev/null
+++ b/make_it_build_fixes.patch
@@ -0,0 +1,12 @@
+diff -Naur qtfm.orig/src/mymodel.cpp qtfm.new/src/mymodel.cpp
+--- qtfm.orig/src/mymodel.cpp 2017-10-28 22:06:56.289345197 +0200
++++ qtfm.new/src/mymodel.cpp 2017-10-28 22:07:36.822507089 +0200
+@@ -220,7 +220,7 @@
+
+ if(item) return item->absoluteFilePath();
+
+- return false;
++ return "This won't work";
+ }
+
+ //---------------------------------------------------------------------------------------