summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian2015-06-11 09:33:00 +0200
committerSebastian2015-06-11 09:33:00 +0200
commita34e96806ad15e73032bf34388b83e4a29f7516f (patch)
tree1464ecd29cd5c7516bbbc2ccf744b5772c6194c2
downloadaur-a34e96806ad15e73032bf34388b83e4a29f7516f.tar.gz
Recommit from AUR
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--qtgain.desktop13
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d58c005850fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qtgain
+ pkgdesc = Simply frontend for mp3gain, vorbisgain and metaflac to replay gain your tracks
+ pkgver = 0.9.8
+ pkgrel = 2
+ url = http://www.qt-apps.org/content/show.php/QtGain?content=56842
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ makedepends = gcc
+ depends = qt4
+ optdepends = mp3gain: For MP3 support
+ optdepends = vorbisgain: For OGG support
+ optdepends = flac: For FLAC suppot
+ optdepends = aacgain: For AAC support
+ source = qtgain::git://git.code.sf.net/p/qtgain/code#commit=b45c51bb5a21c2cd3d275cf63876bcc1242a591c
+ source = qtgain.desktop
+ md5sums = SKIP
+ md5sums = 296ce0f158f8b7d6b80cbfd895e12e5e
+
+pkgname = qtgain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0296bf7fcabf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: AsamK <asamk@gmx.de>
+# Contributor: Artem Sereda <overmind88@gmail.com>
+
+pkgname=qtgain
+pkgver=0.9.8
+pkgrel=2
+pkgdesc="Simply frontend for mp3gain, vorbisgain and metaflac to replay gain your tracks"
+url="http://www.qt-apps.org/content/show.php/QtGain?content=56842"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('qt4')
+makedepends=('make' 'gcc')
+optdepends=('mp3gain: For MP3 support'
+ 'vorbisgain: For OGG support'
+ 'flac: For FLAC suppot'
+ 'aacgain: For AAC support')
+source=("${pkgname}::git://git.code.sf.net/p/qtgain/code#commit=b45c51bb5a21c2cd3d275cf63876bcc1242a591c"
+ 'qtgain.desktop')
+md5sums=('SKIP'
+ '296ce0f158f8b7d6b80cbfd895e12e5e')
+
+build() {
+ cd "$srcdir/${pkgname}"
+ qmake-qt4
+ make
+}
+
+package () {
+ cd "$srcdir/${pkgname}"
+ install -D -m 755 "bin/qtgain" "${pkgdir}/usr/bin/qtgain"
+ install -D -m 644 "${srcdir}/qtgain.desktop" "${pkgdir}/usr/share/applications/qtgain.desktop"
+ install -D -m 644 "Icons/lsongs.png" "${pkgdir}/usr/share/pixmaps/qtgain.png"
+}
diff --git a/qtgain.desktop b/qtgain.desktop
new file mode 100644
index 000000000000..d2306ac418a6
--- /dev/null
+++ b/qtgain.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=/usr/bin/qtgain
+Type=Application
+Categories=Application;AudioVideo;Audio;
+Name=QtGain
+GenericName=QtGain
+Comment=Frontend for mp3gain, vorbisgain and metaflac
+Comment[de]=Frontend für mp3gain, vorbisgain und metaflac
+Comment[ru]=Графическая оболчка для mp3gain, vorbisgain и metaflac
+Terminal=false
+StartupNotify=false
+Icon=/usr/share/pixmaps/qtgain.png