summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat Bakarov2017-05-10 19:10:17 +0700
committerAskhat Bakarov2017-05-10 19:10:17 +0700
commit0672ab5eda53491ee3b122683198d47336792197 (patch)
tree89555b755a6c45877e71aa4941eb9ec1f80ac589
parent760c697c8afdcc40f29f29c6843cba555705742f (diff)
downloadaur-0672ab5eda53491ee3b122683198d47336792197.tar.gz
Build with Qt 5.8, thanks munyamunya for the patch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
-rw-r--r--qtgrace_qt58.patch11
3 files changed, 35 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e554b08a908..765104025f87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Feb 23 13:53:51 UTC 2017
+# Wed May 10 12:05:18 UTC 2017
pkgbase = qtgrace
pkgdesc = A program to display or plot data, analyze data and prepare it for printing, Qt version of the Grace
pkgver = 0.2.6
- pkgrel = 2
+ pkgrel = 3
url = http://plasma-gate.weizmann.ac.il/Grace/
arch = i686
arch = x86_64
license = GPL
- depends = qt4
+ depends = qt5-svg
optdepends = fftw: for better fourier-transformation
optdepends = libharu: for pdf-output
source = http://downloads.sourceforge.net/sourceforge/qtgrace/qtgrace_v026_src.zip
@@ -16,16 +16,19 @@ pkgbase = qtgrace
source = qtgrace.desktop
source = qtgrace-mimetypes
source = qtgrace
+ source = qtgrace_qt58.patch
md5sums = 62691b5e135e6d13177ee070bcd33f24
md5sums = 935df82970eaf9b38b1f5ab26ed45a8d
md5sums = d1bbdd58b4479f4dc27b0bee3d8d0fca
md5sums = 3beba5237f56a2ff28b6cd878865b25c
md5sums = 21b708638a6d63224e05582873be0e4f
+ md5sums = 8188a1396604dd8d1531a8105e514510
sha256sums = e52fdb04f45c992610be37b1cc4ea1366cce255d9a24f19b9521b8e68808c4b1
sha256sums = 53285847eb5214a8ef86593bb1f2791d6e01cfed4bb97323ad86d070ed3f6b98
sha256sums = b8351ba9f8a7cd5033eb453ab56e01771aba02b47d3ab4b70f29b4a138a55a36
sha256sums = 00c16404b9c9386c32a298a3ec8842d2bef8ad6b278a817157ee4af65fcf1479
sha256sums = 7ee2c36f058bbac902fd52b88b2129e43b39c34828281d45342d1b09ac262d79
+ sha256sums = e5de96d5778cb30f4cdf5343d0623cd4d5cdbe17911281b759d047aaae90a55f
pkgname = qtgrace
diff --git a/PKGBUILD b/PKGBUILD
index 91cb2acbdc27..54ca06de4d2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,42 @@ pkgname=qtgrace
pkgver=0.2.6
_pkgver=026
_pkgdirname=qtgrace_v026_src
-pkgrel=2
+pkgrel=3
pkgdesc="A program to display or plot data, analyze data and prepare it for printing, Qt version of the Grace"
arch=('i686' 'x86_64')
url="http://plasma-gate.weizmann.ac.il/Grace/"
#url="http://sourceforge.net/projects/qtgrace/"
license=('GPL')
-depends=('qt4')
+depends=('qt5-svg')
optdepends=('fftw: for better fourier-transformation'
'libharu: for pdf-output')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}_v${_pkgver}_src.zip $pkgname.png $pkgname.desktop $pkgname-mimetypes qtgrace)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}_v${_pkgver}_src.zip $pkgname.png $pkgname.desktop $pkgname-mimetypes qtgrace qtgrace_qt58.patch)
md5sums=('62691b5e135e6d13177ee070bcd33f24'
'935df82970eaf9b38b1f5ab26ed45a8d'
'd1bbdd58b4479f4dc27b0bee3d8d0fca'
'3beba5237f56a2ff28b6cd878865b25c'
- '21b708638a6d63224e05582873be0e4f')
+ '21b708638a6d63224e05582873be0e4f'
+ '8188a1396604dd8d1531a8105e514510')
sha256sums=('e52fdb04f45c992610be37b1cc4ea1366cce255d9a24f19b9521b8e68808c4b1'
'53285847eb5214a8ef86593bb1f2791d6e01cfed4bb97323ad86d070ed3f6b98'
'b8351ba9f8a7cd5033eb453ab56e01771aba02b47d3ab4b70f29b4a138a55a36'
'00c16404b9c9386c32a298a3ec8842d2bef8ad6b278a817157ee4af65fcf1479'
- '7ee2c36f058bbac902fd52b88b2129e43b39c34828281d45342d1b09ac262d79')
+ '7ee2c36f058bbac902fd52b88b2129e43b39c34828281d45342d1b09ac262d79'
+ 'e5de96d5778cb30f4cdf5343d0623cd4d5cdbe17911281b759d047aaae90a55f')
+
+
+prepare()
+{
+ cd "${_pkgdirname}"
+
+ patch -Np0 -i "${srcdir}/qtgrace_qt58.patch"
+}
+
build() {
cd "$srcdir/${_pkgdirname}"
- DESTDIR="${pkgdir}" PREFIX="/usr" qmake-qt4 ./src/src.pro
+ DESTDIR="${pkgdir}" PREFIX="/usr" qmake ./src/src.pro
make
}
@@ -53,3 +64,4 @@ package() {
install -D -m644 "${srcdir}/${pkgname}-mimetypes" "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
}
+
diff --git a/qtgrace_qt58.patch b/qtgrace_qt58.patch
new file mode 100644
index 000000000000..e507f1b98c23
--- /dev/null
+++ b/qtgrace_qt58.patch
@@ -0,0 +1,11 @@
+--- ./src/ListOfLatexCommands.cpp 2017-05-05 14:48:06.871667425 +0500
++++ ./src/ListOfLatexCommands.cpp 2017-05-05 14:48:58.775002136 +0500
+@@ -544,7 +544,7 @@
+ }
+ else
+ {
+- if (com_nr==5 && argument1[0]!='\0')//special case 'frac'
++ if (com_nr==5 && argument1[0].toLatin1()!='\0')//special case 'frac'
+ {
+ int count1,count2;//,max_count;
+ count1=count2=0; \ No newline at end of file