summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroger2015-06-30 10:35:26 -0300
committerroger2015-06-30 10:35:26 -0300
commit61fe3768694411f18109321840d093a28253129c (patch)
treec4ead86c0b23cf1c490bb64e656ce530da2b4f70
downloadaur-61fe3768694411f18109321840d093a28253129c.tar.gz
initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--qtile.install14
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13f3ea642443
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.0
+# Fri Feb 13 16:12:44 UTC 2015
+pkgbase = qtile
+ pkgdesc = A full-featured, pure-Python tiling window manager.
+ pkgver = 0.9.1
+ pkgrel = 2
+ url = http://www.qtile.org
+ install = qtile.install
+ arch = any
+ license = MIT
+ makedepends = python-distribute
+ depends = python
+ depends = pango
+ depends = python-xcffib>=0.1.11
+ depends = python-cairocffi
+ optdepends = python-setproctitle: change the process name to qtile
+ conflicts = qtile-git
+ source = https://github.com/qtile/qtile/archive/v0.9.1.tar.gz
+ md5sums = 0a24f8111d94cb07eae3b276b97fb042
+
+pkgname = qtile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f51e1927c428
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: roger rogerduran at gmail
+
+pkgname=qtile
+pkgver=0.9.1
+pkgrel=2
+pkgdesc="A full-featured, pure-Python tiling window manager."
+arch=('any')
+url="http://www.qtile.org"
+license=('MIT')
+depends=('python' 'pango' 'python-xcffib>=0.1.11' 'python-cairocffi')
+makedepends=('python-distribute')
+optdepends=('python-setproctitle: change the process name to qtile')
+conflicts=('qtile-git')
+install=${pkgname}.install
+source=("https://github.com/qtile/qtile/archive/v${pkgver}.tar.gz")
+md5sums=('0a24f8111d94cb07eae3b276b97fb042')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ # license
+ msg "Copying license..."
+ install -D -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ msg "Copying default config..."
+ install -D -m 644 libqtile/resources/default_config.py $pkgdir/usr/share/doc/$pkgname/default_config.py
+
+ msg "Copying desktop file..."
+ install -D -m 644 resources/qtile.desktop $pkgdir/usr/share/xsessions/qtile.desktop
+
+ # install
+ msg "Running setup.py"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+}
diff --git a/qtile.install b/qtile.install
new file mode 100644
index 000000000000..4352bc9a442d
--- /dev/null
+++ b/qtile.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo ">>> Qtile Example Config at"
+ echo ">>> /usr/share/doc/qtile/default_config.py"
+}
+
+post_upgrade() {
+ echo ">>> Qtile Example Config at"
+ echo ">>> /usr/share/doc/qtile/default_config.py"
+ echo ">>> Since qtile 0.9 qtile.spawn() doesn't use a shell anymore so redirects like > don't work"
+ echo ">>> WARNING: Since 0.9.1 this package moved to python3, if you want to keep using python2, install qtile-python2"
+ echo ">>> WARNING: Maybe you want to run 2to3 ~/.config/qtile/conf.py on your config to try to convert your config to python3"
+}
+
+# vim:set ts=2 sw=2 et: