summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroger2015-06-30 10:39:03 -0300
committerroger2015-06-30 10:39:03 -0300
commitf92d94dd8e5235fc39acbadeda36a486b0a84dce (patch)
tree642fb6898897ae52b12082419707f5de64a4db5b
downloadaur-f92d94dd8e5235fc39acbadeda36a486b0a84dce.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
-rw-r--r--qtile-python2.install12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aec0ac89cf22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.0
+# Fri Feb 13 16:15:54 UTC 2015
+pkgbase = qtile-python2
+ pkgdesc = A full-featured, pure-Python tiling window manager.
+ pkgver = 0.9.1
+ pkgrel = 2
+ url = http://www.qtile.org
+ install = qtile-python2.install
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-trollius
+ depends = pango
+ depends = python2-xcffib>=0.1.11
+ depends = python2-cairocffi
+ optdepends = python2-setproctitle: change the process name to qtile
+ provides = qtile
+ conflicts = qtile
+ source = https://github.com/qtile/qtile/archive/v0.9.1.tar.gz
+ md5sums = 0a24f8111d94cb07eae3b276b97fb042
+
+pkgname = qtile-python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01d3d9085092
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: roger <rogerduran at gmail>
+
+pkgname=qtile-python2
+pkgver=0.9.1
+pkgrel=2
+pkgdesc="A full-featured, pure-Python tiling window manager."
+arch=('any')
+url="http://www.qtile.org"
+license=('MIT')
+depends=('python2' 'python2-trollius' 'pango' 'python2-xcffib>=0.1.11' 'python2-cairocffi')
+makedepends=('python2-distribute')
+optdepends=('python2-setproctitle: change the process name to qtile')
+provides=('qtile')
+conflicts=('qtile')
+install=${pkgname}.install
+source=("https://github.com/qtile/qtile/archive/v${pkgver}.tar.gz")
+md5sums=('0a24f8111d94cb07eae3b276b97fb042')
+
+package() {
+ cd "$srcdir/qtile-$pkgver/"
+ # license
+ msg "Copying license..."
+ install -D -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ msg "Copying default config..."
+ install -D -m 644 libqtile/resources/default_config.py $pkgdir/usr/share/doc/$pkgname/default_config.py
+
+ msg "Copying desktop file..."
+ install -D -m 644 resources/qtile.desktop $pkgdir/usr/share/xsessions/qtile.desktop
+
+ # install
+ msg "Running setup.py"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr
+}
diff --git a/qtile-python2.install b/qtile-python2.install
new file mode 100644
index 000000000000..4c710bda8240
--- /dev/null
+++ b/qtile-python2.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo ">>> Qtile Example Config at"
+ echo ">>> /usr/share/doc/qtile/default_config.py"
+}
+
+post_upgrade() {
+ echo ">>> Qtile Example Config at"
+ echo ">>> /usr/share/doc/qtile/default_config.py"
+ echo ">>> Since qtile 0.9 qtile.spawn() doesn't use a shell anymore so redirects like > don't work"
+}
+
+# vim:set ts=2 sw=2 et: