summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2016-06-27 23:55:47 +0200
committerFélix Piédallu2016-06-27 23:55:47 +0200
commit95dbb9945147c092c4fc390567bade2f042f580f (patch)
treed35c91f0e9d85e79115dd725112d41c3199b5516
downloadaur-95dbb9945147c092c4fc390567bade2f042f580f.tar.gz
first commit
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD58
-rwxr-xr-xbuild.conf116
-rwxr-xr-xqtiplot-git.install13
-rwxr-xr-xqtiplot.desktop15
-rwxr-xr-xqtiplot.xml17
6 files changed, 261 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2761afa7d09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+# Generated by mksrcinfo v8
+# Mon Jun 27 21:55:39 UTC 2016
+pkgbase = qtiplot-git
+ pkgdesc = Data analysis and scientific plotting - free clone of Origin, with Origin import enabled
+ pkgver = 0.9.8.9
+ pkgrel = 1
+ url = http://soft.proindependent.com/qtiplot.html
+ install = qtiplot-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = pkgconfig
+ makedepends = unzip
+ makedepends = boost
+ depends = muparser
+ depends = gsl
+ depends = python2-pyqt
+ depends = boost-libs
+ depends = shared-mime-info
+ depends = glu
+ depends = liborigin2
+ depends = qt-assistant-compat
+ depends = tamu-anova
+ depends = python2
+ depends = qwt
+ depends = qwtplot3d
+ provides = qtiplot
+ conflicts = qtiplot
+ conflicts = qtiplot-opj
+ source = git+https://github.com/Salamandar/qtiplot.git#branch=refactor_build_system
+ source = build.conf
+ source = qtiplot.desktop
+ source = qtiplot-git.install
+ source = qtiplot.xml
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 01838b7c4a13dd368ccfef30a5348df9bef83d98fafe54c129428bd88857fff2
+ sha256sums = dc3bbb78602fa4aafb59c7b33080ac7fe160d2b88c0e296f2b99b1a738d2e972
+ sha256sums = 9656b5de3c31dfc86940c72e7362db13127e252b13522c6eec8f438f71d0ae65
+
+pkgname = qtiplot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dbd07b33541
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: saxonbeta <saxonbeta at gmail dot com>
+# Contributor: sofasurfer <sofasurfer at gmail dot com>
+# Contributor: vicp74 <v1c70rp at gmail dot com>
+# Contributor: Salamandar <felix@piedallu.me>
+
+pkgname=qtiplot-git
+pkgver=0.9.8.9
+pkgrel=1
+pkgdesc="Data analysis and scientific plotting - free clone of Origin, with Origin import enabled"
+# more info in: http://www.staff.science.uu.nl/~zeven101/qtiplot.html
+arch=('i686' 'x86_64')
+url="http://soft.proindependent.com/qtiplot.html"
+license=('GPL2')
+depends=( 'muparser' 'gsl' 'python2-pyqt' 'boost-libs' 'shared-mime-info'
+ 'glu' 'liborigin2' 'qt-assistant-compat' 'tamu-anova' 'python2'
+ 'qwt' 'qwtplot3d')
+makedepends=('pkgconfig' 'unzip' 'boost')
+provides=('qtiplot')
+conflicts=('qtiplot' 'qtiplot-opj')
+
+install=${pkgname}.install
+
+source=("git+https://github.com/Salamandar/qtiplot.git#branch=refactor_build_system"
+ "build.conf"
+ "qtiplot.desktop"
+ "${pkgname}.install"
+ "qtiplot.xml"
+)
+
+sha256sums=('SKIP'
+ 'SKIP'
+ '01838b7c4a13dd368ccfef30a5348df9bef83d98fafe54c129428bd88857fff2'
+ 'dc3bbb78602fa4aafb59c7b33080ac7fe160d2b88c0e296f2b99b1a738d2e972'
+ '9656b5de3c31dfc86940c72e7362db13127e252b13522c6eec8f438f71d0ae65'
+)
+
+prepare() {
+echo "préparation"
+ cp build.conf "$srcdir/qtiplot"
+}
+
+build() {
+echo "buildage"
+ cd "$srcdir/qtiplot"
+
+ lrelease-qt4 qtiplot/translations/*
+ qmake-qt4 qtiplot.pro
+ make
+}
+
+package() {
+ cd "$srcdir/qtiplot"
+ INSTALL_ROOT=${pkgdir} make install
+
+ install -D -m644 "qtiplot_logo.png" "${pkgdir}/usr/share/pixmaps/qtiplot_logo.png"
+ install -D -m644 "../qtiplot.desktop" "${pkgdir}/usr/share/applications/qtiplot.desktop"
+ install -D -m644 "../qtiplot.xml" "${pkgdir}/usr/share/mime/packages/qtiplot.xml"
+}
diff --git a/build.conf b/build.conf
new file mode 100755
index 000000000000..0b14cb0b061c
--- /dev/null
+++ b/build.conf
@@ -0,0 +1,116 @@
+isEmpty( QTI_ROOT ) {
+ message( "each file including this config needs to set QTI_ROOT to the dir containing this file!" )
+}
+
+##########################################################
+## System specific configuration
+##########################################################
+
+# Global include path which is always added at the end of the INCLUDEPATH
+SYS_INCLUDEPATH = /usr/include
+# Global lib path and libs which is ls always added at the end of LIBS
+SYS_LIBS = -L/usr/lib
+
+##########################################################
+## zlib (http://www.zlib.net/)
+##########################################################
+ZLIB_INCLUDEPATH =
+
+##########################################################
+## muParser (http://muparser.sourceforge.net/)
+##########################################################
+MUPARSER_INCLUDEPATH =
+MUPARSER_LIBS = -lmuparser
+
+##########################################################
+## GNU Sientific Library (http://www.gnu.org/software/gsl/)
+##########################################################
+GSL_INCLUDEPATH = $$SYS_INCLUDEPATH/gsl
+GSL_LIBS = -lgsl -lgslcblas
+
+##########################################################
+## QWT - use local copy till upstream catches up
+# http://qwt.sourceforge.net/index.html
+##########################################################
+QWT_INCLUDEPATH = $$QTI_ROOT/3rdparty/qwt/src
+QWT_LIBS = $$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
+
+##########################################################
+## QwtPlot3D - use local copy till upstream catches up
+# http://qwtplot3d.sourceforge.net/
+##########################################################
+QWT3D_INCLUDEPATH = $$QTI_ROOT/3rdparty/qwtplot3d/include
+win32:QWT3D_LIBS = $$QTI_ROOT/3rdparty/qwtplot3d/lib/qwtplot3d.dll
+unix:QWT3D_LIBS = $$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
+
+##########################################################
+## libpng - optional. you don't have to set these variables
+##########################################################
+LIBPNG_INCLUDEPATH =
+LIBPNG_LIBS = -lpng
+
+##########################################################
+## QTeXEngine - optional. you don't have to set these variables
+# http://soft.proindependent.com/qtexengine/
+##########################################################
+TEX_ENGINE_INCLUDEPATH = $$QTI_ROOT/3rdparty/QTeXEngine/src
+TEX_ENGINE_LIBS = $$QTI_ROOT/3rdparty/QTeXEngine/libQTeXEngine.a
+
+##########################################################
+## ALGLIB (2.6) - optional. you don't have to set these variables
+# http://www.alglib.net/
+##########################################################
+#ALGLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/alglib/out
+#ALGLIB_LIBS = $$QTI_ROOT/3rdparty/alglib/out/libalglib.a
+
+##########################################################
+## TAMUANOVA - optional. you don't have to set these variables
+# http://www.stat.tamu.edu/~aredd/tamuanova/
+##########################################################
+TAMUANOVA_INCLUDEPATH = $$SYS_INCLUDEPATH/tamu_anova/
+TAMUANOVA_LIBS = -ltamuanova
+
+##########################################################
+## python - only used if python is needed
+##########################################################
+
+# the python interpreter to use
+# (unix only, windows will use what ever is configured to execute .py files!)
+PYTHON = python2
+
+##########################################################
+## Qt tools - allows to use specific versions
+##########################################################
+
+LUPDATE = lupdate
+LRELEASE = lrelease
+
+############################################################
+## Target specific configuration: configure Qtiplot itself
+############################################################
+
+contains( TARGET, qtiplot ) {
+ # building without muParser doesn't work yet
+ SCRIPTING_LANGS += muParser
+ SCRIPTING_LANGS += Python
+
+ # a console displaying output of scripts; particularly useful on Windows
+ # where running QtiPlot from a terminal is inconvenient
+ DEFINES += SCRIPTING_CONSOLE
+
+ DEFINES += QTIPLOT_PRO
+
+ # Uncomment the following line if you want to perform a custom installation using the *.path variables defined in ./qtiplot.pro.
+ CONFIG += CustomInstall
+
+ # Uncomment the following line if you want to build QtiPlot as a browser plugin (not working on Internet Explorer).
+ #CONFIG += BrowserPlugin
+
+ CONFIG += release
+ #CONFIG += debug
+
+ # Uncomment the following line if you want to link statically against Qt.
+ #CONFIG += StaticBuild
+
+ #win32: CONFIG += console
+}
diff --git a/qtiplot-git.install b/qtiplot-git.install
new file mode 100755
index 000000000000..251ab05ea3b1
--- /dev/null
+++ b/qtiplot-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "Updating MIME type for QtiPlot project file"
+ update-mime-database /usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove () {
+ post_install
+}
+
diff --git a/qtiplot.desktop b/qtiplot.desktop
new file mode 100755
index 000000000000..56c11bc14a5d
--- /dev/null
+++ b/qtiplot.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+#Encoding=UTF-8
+Type=Application
+Exec=qtiplot
+MimeType=application/x-qtiplot;application/x-qtiplot-project-backup;
+Comment=An application for plotting and analysis of data sets and functions
+Comment[de]=Ein Programm zum Plotten und analysieren von Daten und Funktionen
+Comment[es]=Aplicación para graficar y analizar datos y funciones
+Terminal=false
+Name=QtiPlot
+#Protocols=file
+Icon=/usr/share/pixmaps/qtiplot_logo.png
+# Categories=QT;KDE;Science;Utility;X-KDE-More
+# Categories=Qt;KDE;Math;Education
+Categories=Science;X-Plotting;
diff --git a/qtiplot.xml b/qtiplot.xml
new file mode 100755
index 000000000000..7fc7fc743a04
--- /dev/null
+++ b/qtiplot.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <!-- <mime-type type="application/x-qtiplot-project">
+ <sub-class-of type="text/plain"/>
+ <comment>QtiPlot project file</comment>
+ <glob pattern="*.qti" />
+ </mime-type>
+ <mime-type type="application/x-qtiplot-project-compressed">
+ <comment>Compressed QtiPlot project file</comment>
+ <glob pattern="*.qti.gz" />
+ </mime-type> -->
+ <mime-type type="application/x-qtiplot-project-backup">
+ <sub-class-of type="text/plain"/>
+ <comment>QtiPlot project file backup</comment>
+ <glob pattern="*.qti~" />
+ </mime-type>
+</mime-info>