summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Falezza2019-12-30 13:12:14 +0100
committerFilippo Falezza2019-12-30 13:12:14 +0100
commit0cef1f9e9075d9fc3e068947c1fe0c85fea22212 (patch)
treefdb548b0de50db98def407a8ff6ef5c0e9355416
parentdab23eb8a8ce1118d76e999db7094c85f8b9dfa4 (diff)
downloadaur-0cef1f9e9075d9fc3e068947c1fe0c85fea22212.tar.gz
PlotDialog patch fixed
-rw-r--r--PKGBUILD2
-rw-r--r--PlotDialog.patch20
2 files changed, 20 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5e3930ea7dc..8a1664af40a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,7 +63,7 @@ sha256sums=('a523ea259516d7581abaf2fe376507d152db32f71d88176cff18f5bc391b9ef0'
'e5476599521289928e50462f6c9080185581f0c15b2dc274c96ca2c1fd8fa72a'
'da119d0d4abdf8954f7fc52efc9fc738897e4bdcc9b767444e549fb00a62578a'
'2427a152acdbe312211b7d57e73d47e9cd7f698440952784de6db4c0429cea22'
- "00eeac1a809be949d64b8594b39c868488027d9f80eed3aa6786a86ad44eb5f4")
+ "5eda5e19bf54fe00e15082987fd6a3e6833a393773fb35e6bd89d453f3585a3f")
prepare() {
cd "$srcdir"
diff --git a/PlotDialog.patch b/PlotDialog.patch
index 20372a470b76..62725598aa73 100644
--- a/PlotDialog.patch
+++ b/PlotDialog.patch
@@ -1,5 +1,23 @@
--- qtiplot-0.9.8.9/qtiplot/src/plot2D/dialogs/PlotDialog.cpp 2011-09-13 13:50:34.000000000 +0200
-+++ qtiplot-0.9.8.9/qtiplot/src/plot2D/dialogs/PlotDialog.cpp 2019-12-30 12:49:57.000000000 +0100
++++ qtiplot-0.9.8.9/qtiplot/src/plot2D/dialogs/PlotDialog.cpp 2019-12-30 13:02:37.914353805 +0100
+@@ -954,7 +954,7 @@
+ l4->setBuddy(boxFirstColor);
+ gl2->addWidget(l4, 0, 0);
+
+- boxPiePattern = new PatternBox(false);
++ boxPiePattern = new PatternBox();
+ gl2->addWidget(boxPiePattern, 1, 1);
+ gl2->setRowStretch(2, 1);
+
+@@ -1337,7 +1337,7 @@
+ hb->addWidget(boxCurveOpacity);
+ gl2->addLayout(hb, 1, 1);
+
+- boxPattern = new PatternBox(false);
++ boxPattern = new PatternBox();
+ gl2->addWidget(boxPattern, 2, 1);
+
+ QLabel *l6 = new QLabel("&" + tr("Pattern"));
@@ -2126,17 +2126,17 @@
QGridLayout *gl3 = new QGridLayout(GroupBoxVectEnd);
labelXEnd = new QLabel(tr( "X End" ));