summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaxonbeta2015-06-09 08:09:26 -0500
committersaxonbeta2015-06-09 08:09:26 -0500
commitaadd14653ad00c8158c0151dd24356e667de05a2 (patch)
treef84e474b52313e69453a176fe94778546d12e0e3
downloadaur-aadd14653ad00c8158c0151dd24356e667de05a2.tar.gz
Initial import
-rw-r--r--.SRCINFO58
-rwxr-xr-xPKGBUILD87
-rwxr-xr-xbuild.conf149
-rwxr-xr-xopj.tar.bz2bin0 -> 145373 bytes
-rwxr-xr-xpyqt4.patch12
-rwxr-xr-xpython-sipcmd.py37
-rwxr-xr-xqtiplot-0.9.8.9-FFT.patch40
-rwxr-xr-xqtiplot-0.9.8.9-FFTcpp.patch43
-rwxr-xr-xqtiplot-0.9.8.9-dialog.patch18
-rwxr-xr-xqtiplot-0.9.8.9-image_widget.patch24
-rwxr-xr-xqtiplot-0.9.8.9-set_col_values.patch17
-rwxr-xr-xqtiplot-opj.install13
-rwxr-xr-xqtiplot.desktop13
-rwxr-xr-xqtiplot.patch212
-rwxr-xr-xqtiplot.xml17
15 files changed, 740 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f460f7e7638d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,58 @@
+pkgbase = qtiplot-opj
+ pkgdesc = Data analysis and scientific plotting - free clone of Origin, with Origin import enabled
+ pkgver = 0.9.8.9
+ pkgrel = 12
+ url = http://soft.proindependent.com/qtiplot.html
+ install = qtiplot-opj.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = pkgconfig
+ makedepends = unzip
+ makedepends = boost
+ depends = muparser
+ depends = gsl
+ depends = python2-pyqt
+ depends = boost-libs
+ depends = shared-mime-info
+ depends = glu
+ depends = liborigin2
+ depends = qt-assistant-compat
+ depends = tamu-anova
+ depends = python2
+ provides = qtiplot
+ conflicts = qtiplot
+ noextract = opj.tar.bz2
+ noextract = QTeXEngine-0.3-opensource.zip
+ options = !makeflags
+ source = http://downloads.sourceforge.net/project/qtiplot.berlios/qtiplot-0.9.8.9.tar.bz2
+ source = http://downloads.sourceforge.net/project/qtiplot.berlios/QTeXEngine-0.3-opensource.zip
+ source = opj.tar.bz2
+ source = qtiplot.patch
+ source = qtiplot-0.9.8.9-set_col_values.patch
+ source = qtiplot-0.9.8.9-image_widget.patch
+ source = qtiplot-0.9.8.9-FFT.patch
+ source = qtiplot-0.9.8.9-FFTcpp.patch
+ source = qtiplot-0.9.8.9-dialog.patch
+ source = qtiplot.desktop
+ source = qtiplot.xml
+ source = qtiplot-opj.install
+ source = build.conf
+ source = pyqt4.patch
+ md5sums = 652096a365851da3b5f6fefdcbe2aaec
+ md5sums = d1b234623770ec6209b14d1b5137f2f1
+ md5sums = 8a6bdb368ab264e36a5210d8ce0f5439
+ md5sums = c84feb6ed8836ed5868b3fe5887dc1c3
+ md5sums = a0a9a28722d8c58c6e3f5bea816eed09
+ md5sums = 23c4758e557c30c791c332ece6f63f0d
+ md5sums = 66ab87e227dc1436d8a08adaef657d74
+ md5sums = 354648b6702d7b7fb71d7d230b6a9bbf
+ md5sums = a433c4c2187a0a988ed849e486349297
+ md5sums = 6e990ff9c3a456b446b581492ddf669c
+ md5sums = 35683f3b32e1edcca0bb02c471d284e9
+ md5sums = 58b7f423e59db7764f53988cdbd7308e
+ md5sums = b5e7832b05c991c80b83964670d00af8
+ md5sums = d71623b74a9264225a438553f230cc40
+
+pkgname = qtiplot-opj
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..69d52e89d32c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Maintainer: saxonbeta <saxonbeta at gmail dot com>
+# Contributor: sofasurfer <sofasurfer at gmail dot com>
+# Contributor:vicp74 <v1c70rp at gmail dot com>
+
+pkgname=qtiplot-opj
+pkgver=0.9.8.9
+pkgrel=12
+pkgdesc="Data analysis and scientific plotting - free clone of Origin, with Origin import enabled"
+# more info in: http://www.staff.science.uu.nl/~zeven101/qtiplot.html
+arch=('i686' 'x86_64')
+url="http://soft.proindependent.com/qtiplot.html"
+license=('GPL2')
+depends=('muparser' 'gsl' 'python2-pyqt' 'boost-libs' 'shared-mime-info' 'glu' 'liborigin2' \
+ 'qt-assistant-compat' 'tamu-anova' 'python2')
+makedepends=('pkgconfig' 'unzip' 'boost')
+provides=('qtiplot')
+conflicts=('qtiplot')
+options=('!makeflags')
+install=${pkgname}.install
+
+source=("http://downloads.sourceforge.net/project/qtiplot.berlios/qtiplot-${pkgver}.tar.bz2"
+"http://downloads.sourceforge.net/project/qtiplot.berlios/QTeXEngine-0.3-opensource.zip"
+"opj.tar.bz2"
+"qtiplot.patch"
+"qtiplot-0.9.8.9-set_col_values.patch"
+"qtiplot-0.9.8.9-image_widget.patch"
+"qtiplot-0.9.8.9-FFT.patch"
+"qtiplot-0.9.8.9-FFTcpp.patch"
+"qtiplot-0.9.8.9-dialog.patch"
+"qtiplot.desktop"
+"qtiplot.xml"
+"qtiplot-opj.install"
+"build.conf"
+"pyqt4.patch"
+)
+
+noextract=("opj.tar.bz2"
+ "QTeXEngine-0.3-opensource.zip"
+)
+
+md5sums=('652096a365851da3b5f6fefdcbe2aaec'
+'d1b234623770ec6209b14d1b5137f2f1'
+'8a6bdb368ab264e36a5210d8ce0f5439'
+'c84feb6ed8836ed5868b3fe5887dc1c3'
+'a0a9a28722d8c58c6e3f5bea816eed09'
+'23c4758e557c30c791c332ece6f63f0d'
+'66ab87e227dc1436d8a08adaef657d74'
+'354648b6702d7b7fb71d7d230b6a9bbf'
+'a433c4c2187a0a988ed849e486349297'
+'6e990ff9c3a456b446b581492ddf669c'
+'35683f3b32e1edcca0bb02c471d284e9'
+'58b7f423e59db7764f53988cdbd7308e'
+'b5e7832b05c991c80b83964670d00af8'
+'d71623b74a9264225a438553f230cc40'
+)
+
+build() {
+cd "$srcdir"
+
+tar xf qtiplot-${pkgver}.tar.bz2
+tar xvf opj.tar.bz2 -C qtiplot-${pkgver}/
+unzip -o QTeXEngine-0.3-opensource.zip -d qtiplot-${pkgver}/3rdparty
+
+patch -p0 < qtiplot-0.9.8.9-set_col_values.patch
+patch -p0 < qtiplot-0.9.8.9-image_widget.patch
+patch -p0 < qtiplot-0.9.8.9-FFT.patch
+patch -p0 < qtiplot-0.9.8.9-FFTcpp.patch
+patch -p0 < qtiplot-0.9.8.9-dialog.patch
+patch -p0 < qtiplot.patch
+patch -p0 < pyqt4.patch
+cp build.conf qtiplot-${pkgver}/
+cd "qtiplot-${pkgver}"
+lrelease-qt4 qtiplot/translations/*
+qmake-qt4 qtiplot.pro
+make
+
+}
+package() {
+cd "$srcdir/qtiplot-${pkgver}"
+
+INSTALL_ROOT=${pkgdir} make install
+
+install -D -m644 "${srcdir}/qtiplot-${pkgver}/qtiplot_logo.png" "${pkgdir}/usr/share/pixmaps/qtiplot_logo.png"
+install -D -m644 "${srcdir}/qtiplot.desktop" "${pkgdir}/usr/share/applications/qtiplot.desktop"
+install -D -m644 "${srcdir}/qtiplot.xml" "${pkgdir}/usr/share/mime/packages/qtiplot.xml"
+
+}
diff --git a/build.conf b/build.conf
new file mode 100755
index 000000000000..158916a22e16
--- /dev/null
+++ b/build.conf
@@ -0,0 +1,149 @@
+isEmpty( QTI_ROOT ) {
+ message( "each file including this config needs to set QTI_ROOT to the dir containing this file!" )
+}
+
+##########################################################
+## System specific configuration
+##########################################################
+
+# Global include path which is always added at the end of the INCLUDEPATH
+SYS_INCLUDEPATH = /usr/include
+# Global lib path and libs which is ls always added at the end of LIBS
+SYS_LIBS = -L/usr/lib
+
+##########################################################
+## zlib (http://www.zlib.net/)
+##########################################################
+
+# include path. leave it blank to use SYS_INCLUDE
+#ZLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/zlib/
+
+##########################################################
+## muParser (http://muparser.sourceforge.net/)
+##########################################################
+
+# include path. leave it blank to use SYS_INCLUDE
+#MUPARSER_INCLUDEPATH = $$QTI_ROOT/3rdparty/muparser/include
+# link statically against a copy in 3rdparty/
+#MUPARSER_LIBS = $$QTI_ROOT/3rdparty/muparser/lib/libmuparser.a
+# or dynamically against a system-wide installation
+MUPARSER_LIBS = -lmuparser
+
+##########################################################
+## GNU Sientific Library (http://www.gnu.org/software/gsl/)
+##########################################################
+
+# include path. leave it blank to use SYS_INCLUDE
+GSL_INCLUDEPATH = /usr/include/gsl
+# link statically against a copy in 3rdparty/
+#GSL_LIBS = $$QTI_ROOT/3rdparty/gsl/lib/libgsl.a \
+# $$QTI_ROOT/3rdparty/gsl/lib/libgslcblas.a
+# or dynamically against a system-wide installation
+GSL_LIBS = -lgsl -lgslcblas
+
+##########################################################
+## QWT - use local copy till upstream catches up
+# http://qwt.sourceforge.net/index.html
+##########################################################
+
+# include path.
+QWT_INCLUDEPATH = $$QTI_ROOT/3rdparty/qwt/src
+# link locally against a copy in 3rdparty/
+QWT_LIBS = $$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
+
+##########################################################
+## QwtPlot3D - use local copy till upstream catches up
+# http://qwtplot3d.sourceforge.net/
+##########################################################
+
+# include path.
+QWT3D_INCLUDEPATH = $$QTI_ROOT/3rdparty/qwtplot3d/include
+# link locally against a copy in 3rdparty/
+win32:QWT3D_LIBS = $$QTI_ROOT/qwtplot3d.dll
+unix:QWT3D_LIBS = $$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
+
+##########################################################
+## libpng - optional. you don't have to set these variables
+##########################################################
+
+# include path. leave it blank to use SYS_INCLUDE
+#LIBPNG_INCLUDEPATH = c:/mingw/include
+# link statically against a copy in 3rdparty/
+#LIBPNG_LIBS = c:/mingw/bin/libpng3.dll
+# or dynamically against a system-wide installation
+LIBPNG_LIBS = -lpng
+
+##########################################################
+## QTeXEngine - optional. you don't have to set these variables
+# http://soft.proindependent.com/qtexengine/
+##########################################################
+
+# include path.
+TEX_ENGINE_INCLUDEPATH = $$QTI_ROOT/3rdparty/QTeXEngine/src
+# link locally against a copy in 3rdparty/
+TEX_ENGINE_LIBS = $$QTI_ROOT/3rdparty/QTeXEngine/libQTeXEngine.a
+
+##########################################################
+## ALGLIB (2.6) - optional. you don't have to set these variables
+# http://www.alglib.net/
+##########################################################
+
+# include path.
+#ALGLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/alglib/out
+# link locally against a copy in 3rdparty/
+#ALGLIB_LIBS = $$QTI_ROOT/3rdparty/alglib/out/libalglib.a
+
+##########################################################
+## TAMUANOVA - optional. you don't have to set these variables
+# http://www.stat.tamu.edu/~aredd/tamuanova/
+##########################################################
+
+# include path.
+TAMUANOVA_INCLUDEPATH = /usr/include/tamu_anova/
+# link locally against a copy in 3rdparty/
+TAMUANOVA_LIBS = /usr/lib/libtamuanova.a
+
+##########################################################
+## python - only used if python is needed
+##########################################################
+
+# the python interpreter to use
+# (unix only, windows will use what ever is configured to execute .py files!)
+PYTHON = python2
+
+##########################################################
+## Qt tools - allows to use specific versions
+##########################################################
+
+LUPDATE = lupdate
+LRELEASE = lrelease
+
+############################################################
+## Target specific configuration: configure Qtiplot itself
+############################################################
+
+contains( TARGET, qtiplot ) {
+ # building without muParser doesn't work yet
+ SCRIPTING_LANGS += muParser
+ SCRIPTING_LANGS += Python
+
+ # a console displaying output of scripts; particularly useful on Windows
+ # where running QtiPlot from a terminal is inconvenient
+ DEFINES += SCRIPTING_CONSOLE
+
+ DEFINES += QTIPLOT_PRO
+
+ # Uncomment the following line if you want to perform a custom installation using the *.path variables defined in ./qtiplot.pro.
+ CONFIG += CustomInstall
+
+ # Uncomment the following line if you want to build QtiPlot as a browser plugin (not working on Internet Explorer).
+ #CONFIG += BrowserPlugin
+
+ CONFIG += release
+ #CONFIG += debug
+
+ # Uncomment the following line if you want to link statically against Qt.
+ #CONFIG += StaticBuild
+
+ #win32: CONFIG += console
+}
diff --git a/opj.tar.bz2 b/opj.tar.bz2
new file mode 100755
index 000000000000..e382ae0915d9
--- /dev/null
+++ b/opj.tar.bz2
Binary files differ
diff --git a/pyqt4.patch b/pyqt4.patch
new file mode 100755
index 000000000000..087968e23fa1
--- /dev/null
+++ b/pyqt4.patch
@@ -0,0 +1,12 @@
++++ qtiplot-0.9.8.9/qtiplot/python-sipcmd.py 2014-08-26 18:54:14.141685971 -0500
+@@ -27,6 +27,7 @@
+ # #
+ ############################################################################
+
+-from PyQt4 import pyqtconfig
+-config = pyqtconfig.Configuration()
+-print " ".join([config.sip_bin, "-I", config.pyqt_sip_dir, config.pyqt_sip_flags])
++from PyQt4 import QtCore
++import sipconfig
++sipcfg = sipconfig.Configuration()
++print " ".join([sipcfg.sip_bin, "-I", sipcfg.default_sip_dir + "/PyQt4", QtCore.PYQT_CONFIGURATION['sip_flags']])
diff --git a/python-sipcmd.py b/python-sipcmd.py
new file mode 100755
index 000000000000..556494f0d8e5
--- /dev/null
+++ b/python-sipcmd.py
@@ -0,0 +1,37 @@
+#!/usr/bin/python
+
+############################################################################
+# #
+# File : python-sipcmd.py #
+# Project : QtiPlot #
+# Description : Auto-detect SIP/PyQt location; dump commandline #
+# Copyright : (C) 2007-2010 Knut Franke (knut.franke*gmx.de) #
+# (replace * with @ in the email address) #
+# #
+############################################################################
+# #
+# This program is free software; you can redistribute it and/or modify #
+# it under the terms of the GNU General Public License as published by #
+# the Free Software Foundation; either version 2 of the License, or #
+# (at your option) any later version. #
+# #
+# This program is distributed in the hope that it will be useful, #
+# but WITHOUT ANY WARRANTY; without even the implied warranty of #
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the #
+# GNU General Public License for more details. #
+# #
+# You should have received a copy of the GNU General Public License #
+# along with this program; if not, write to the Free Software #
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, #
+# Boston, MA 02110-1301 USA #
+# #
+############################################################################
+
+import PyQt4 as PyQt
+from PyQt4 import QtCore
+import sipconfig
+import os
+sipcfg = sipconfig.Configuration()
+print " ".join([sipcfg.default_sip_dir , PyQt.__name__])
+
+print " ".join([sipcfg.sip_bin, "-I", sipcfg.default_sip_dir, QtCore.PYQT_CONFIGURATION['sip_flags']])
diff --git a/qtiplot-0.9.8.9-FFT.patch b/qtiplot-0.9.8.9-FFT.patch
new file mode 100755
index 000000000000..cec3fa13dd35
--- /dev/null
+++ b/qtiplot-0.9.8.9-FFT.patch
@@ -0,0 +1,40 @@
+--- qtiplot-0.9.8.9/qtiplot/src/analysis/FFT.h 2013-09-01 11:53:45.200163882 -0300
+***************
+*** 36,42 ****
+ Q_OBJECT
+
+ public:
+! FFT(ApplicationWindow *parent, Table *t, const QString& realColName, const QString& imagColName = QString(), int from = 1, int to = -1);
+ FFT(ApplicationWindow *parent, QwtPlotCurve *c);
+ FFT(ApplicationWindow *parent, QwtPlotCurve *c, double start, double end);
+ FFT(ApplicationWindow *parent, Graph *g, const QString& curveTitle);
+--- 36,42 ----
+ Q_OBJECT
+
+ public:
+! FFT(ApplicationWindow *parent, Table *t, const QString& realColName, const QString& imagColName = QString(), int from = 1, int to = -1, bool foo = false);
+ FFT(ApplicationWindow *parent, QwtPlotCurve *c);
+ FFT(ApplicationWindow *parent, QwtPlotCurve *c, double start, double end);
+ FFT(ApplicationWindow *parent, Graph *g, const QString& curveTitle);
+***************
+*** 52,57 ****
+--- 52,59 ----
+ Matrix *realOutputMatrix(){return d_re_out_matrix;}
+ Matrix *imaginaryOutputMatrix(){return d_im_out_matrix;}
+
++ bool setDataFromTable(Table *t, const QString& realColName, const QString& imagColName = QString(), int from = 0, int to = -1, bool foo = false);
++
+ private:
+ void init();
+ void output();
+***************
+*** 60,67 ****
+ void fftTable();
+ void fftMatrix();
+
+- bool setDataFromTable(Table *t, const QString& realColName, const QString& imagColName = QString(), int from = 0, int to = -1);
+-
+ double d_sampling;
+ //! Flag telling if an inverse FFT must be performed.
+ bool d_inverse;
+--- 62,67 ----
diff --git a/qtiplot-0.9.8.9-FFTcpp.patch b/qtiplot-0.9.8.9-FFTcpp.patch
new file mode 100755
index 000000000000..abe661be81da
--- /dev/null
+++ b/qtiplot-0.9.8.9-FFTcpp.patch
@@ -0,0 +1,43 @@
+--- qtiplot-0.9.8.9/qtiplot/src/analysis/FFT.cpp 2013-09-01 11:36:10.742543036 -0300
+***************
+*** 39,49 ****
+ #include <gsl/gsl_fft_complex.h>
+ #include <gsl/gsl_fft_halfcomplex.h>
+
+! FFT::FFT(ApplicationWindow *parent, Table *t, const QString& realColName, const QString& imagColName, int from, int to)
+ : Filter(parent, t)
+ {
+ init();
+! setDataFromTable(t, realColName, imagColName, from, to);
+ }
+
+ FFT::FFT(ApplicationWindow *parent, QwtPlotCurve *c)
+--- 39,49 ----
+ #include <gsl/gsl_fft_complex.h>
+ #include <gsl/gsl_fft_halfcomplex.h>
+
+! FFT::FFT(ApplicationWindow *parent, Table *t, const QString& realColName, const QString& imagColName, int from, int to, bool foo)
+ : Filter(parent, t)
+ {
+ init();
+! setDataFromTable(t, realColName, imagColName, from, to, foo);
+ }
+
+ FFT::FFT(ApplicationWindow *parent, QwtPlotCurve *c)
+***************
+*** 353,359 ****
+ ml->arrangeLayers(false, false);
+ }
+
+! bool FFT::setDataFromTable(Table *t, const QString& realColName, const QString& imagColName, int from, int to)
+ {
+ d_init_err = true;
+
+--- 353,359 ----
+ ml->arrangeLayers(false, false);
+ }
+
+! bool FFT::setDataFromTable(Table *t, const QString& realColName, const QString& imagColName, int from, int to, bool foo)
+ {
+ d_init_err = true;
+
diff --git a/qtiplot-0.9.8.9-dialog.patch b/qtiplot-0.9.8.9-dialog.patch
new file mode 100755
index 000000000000..3859bfa10f93
--- /dev/null
+++ b/qtiplot-0.9.8.9-dialog.patch
@@ -0,0 +1,18 @@
+--- qtiplot-0.9.8.9/qtiplot/src/analysis/dialogs/FFTDialog.cpp 2013-09-01 12:21:03.957954932 -0300
+***************
+*** 187,193 ****
+ boxReal->setFocus();
+ return;
+ }
+! fft = new FFT(app, d_table, boxReal->currentText(), boxImaginary->currentText());
+ }
+ fft->setInverseFFT(backwardBtn->isChecked());
+ fft->setSampling(boxSampling->value());
+--- 187,193 ----
+ boxReal->setFocus();
+ return;
+ }
+! fft = new FFT(app, d_table, boxReal->currentText(), boxImaginary->currentText(), false);
+ }
+ fft->setInverseFFT(backwardBtn->isChecked());
+ fft->setSampling(boxSampling->value());
diff --git a/qtiplot-0.9.8.9-image_widget.patch b/qtiplot-0.9.8.9-image_widget.patch
new file mode 100755
index 000000000000..f7556a9dd1e0
--- /dev/null
+++ b/qtiplot-0.9.8.9-image_widget.patch
@@ -0,0 +1,24 @@
+--- qtiplot-0.9.8.9/qtiplot/src/plot2D/ImageWidget.h 2013-09-01 01:05:00.681152827 -0300
+***************
+*** 67,76 ****
+ void setWindowName(const QString& name){d_window_name = name;};
+
+ static QPixmap windowPixmap(ApplicationWindow *mw, const QString& name, const QSize& size);
+
+ private:
+ void draw(QPainter *painter, const QRect& r);
+- void paintEvent(QPaintEvent *e);
+ QPixmap d_pix;
+ //! The file from which the image was loaded.
+ QString d_file_name;
+--- 67,76 ----
+ void setWindowName(const QString& name){d_window_name = name;};
+
+ static QPixmap windowPixmap(ApplicationWindow *mw, const QString& name, const QSize& size);
++ void paintEvent(QPaintEvent *e);
+
+ private:
+ void draw(QPainter *painter, const QRect& r);
+ QPixmap d_pix;
+ //! The file from which the image was loaded.
+ QString d_file_name;
diff --git a/qtiplot-0.9.8.9-set_col_values.patch b/qtiplot-0.9.8.9-set_col_values.patch
new file mode 100755
index 000000000000..12359f7e54e5
--- /dev/null
+++ b/qtiplot-0.9.8.9-set_col_values.patch
@@ -0,0 +1,17 @@
+Description: if you don't initialize the "i" variable, or initialize it to 0.0
+ qtiplot won't let you set the column values using muparser.
+Author: Scott Howard <showard@debian.org>
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707736
+
+Index: qtiplot/qtiplot/src/table/Table.cpp
+===================================================================
+--- qtiplot-0.9.8.9/qtiplot/src/table/Table.cpp 2013-06-08 02:06:35.550201324 -0400
+@@ -564,7 +564,7 @@
+ QApplication::setOverrideCursor(QCursor(Qt::WaitCursor));
+
+ muParserScript *mup = new muParserScript(scriptEnv, cmd, this, QString("<%1>").arg(colName(col)));
+- double *r = mup->defineVariable("i");
++ double *r = mup->defineVariable("i",startRow + 1.0);
+ mup->defineVariable("j", (double)col);
+ mup->defineVariable("sr", startRow + 1.0);
+ mup->defineVariable("er", endRow + 1.0);
diff --git a/qtiplot-opj.install b/qtiplot-opj.install
new file mode 100755
index 000000000000..251ab05ea3b1
--- /dev/null
+++ b/qtiplot-opj.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "Updating MIME type for QtiPlot project file"
+ update-mime-database /usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove () {
+ post_install
+}
+
diff --git a/qtiplot.desktop b/qtiplot.desktop
new file mode 100755
index 000000000000..84af1db4f787
--- /dev/null
+++ b/qtiplot.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Exec=qtiplot
+Comment=An application for plotting and analysis of data sets and functions
+Comment[de]=Ein Programm zum Plotten und analysieren von Daten und Funktionen
+Terminal=false
+Name=QtiPlot
+Protocols=file
+Icon=/usr/share/pixmaps/qtiplot_logo.png
+# Categories=QT;KDE;Science;Utility;X-KDE-More
+# Categories=Qt;KDE;Math;Education
+Categories=Science;X-Plotting;
diff --git a/qtiplot.patch b/qtiplot.patch
new file mode 100755
index 000000000000..a7c08b5dd43b
--- /dev/null
+++ b/qtiplot.patch
@@ -0,0 +1,212 @@
+--- qtiplot-0.9.8.9/qtiplot/src/core/ApplicationWindow.cpp 2011-11-01 13:21:13.000000000 +0100
+@@ -2,6 +2,7 @@
+ File : ApplicationWindow.cpp
+ Project : QtiPlot
+ --------------------------------------------------------------------
++ Copyright � 2011 Stephan Zevenhuizen
+ Copyright : (C) 2004 - 2011 by Ion Vasilief,
+ (C) 2006 - June 2007 Tilman Hoener zu Siederdissen, Knut Franke
+ Email (use @ for *) : ion_vasilief*yahoo.fr
+@@ -174,7 +175,7 @@
+ #include <QVarLengthArray>
+ #include <QList>
+ #include <QUrl>
+-#include <QAssistantClient>
++#include <qassistantclient.h>
+ #include <QFontComboBox>
+ #include <QSpinBox>
+ #include <QMdiArea>
+@@ -9830,7 +9831,7 @@
+ if (dialog){
+ QString text = "<h2>"+ versionString() + "</h2>";
+ text += "<h3>" + QString(copyright_string).replace("\n", "<br>") + "</h3>";
+- text += "<h3>" + tr("Released") + ": " + QString(release_date) + "</h3>";
++ text += "<h3>" + QString("CMI - Universiteit Utrecht release") + "</h3>";
+
+ QMessageBox *mb = new QMessageBox();
+ mb->setAttribute(Qt::WA_DeleteOnClose);
+
+--- qtiplot-0.9.8.9/qtiplot/src/core/main.cpp 2011-02-18 08:16:46.000000000 +0100
+@@ -2,6 +2,7 @@
+ File : main.cpp
+ Project : QtiPlot
+ --------------------------------------------------------------------
++ Copyright � 2011 Stephan Zevenhuizen
+ Copyright : (C) 2004 - 2011 by Ion Vasilief
+ Email (use @ for *) : ion_vasilief*yahoo.fr
+ Description : QtiPlot main function
+@@ -130,7 +131,7 @@
+ Q_IMPORT_PLUGIN(qtiff);
+ #endif
+
+-#ifdef QTIPLOT_PRO
++#ifdef QTIPLOT_CLOSED_SOURCE
+ Q_IMPORT_PLUGIN(QtiPlotdBasePlugin);
+ Q_IMPORT_PLUGIN(QtiPlotCsvPlugin);
+ Q_IMPORT_PLUGIN(QtiPlotTexPlugin);
+@@ -140,6 +141,9 @@
+ Q_IMPORT_PLUGIN(QtiPlotOriginPlugin);
+ Q_IMPORT_PLUGIN(QtiPlotDatabasePlugin);
+ #endif
++
++ Q_IMPORT_PLUGIN(FreeSoftwareQtiPlotImportOPJ);
++
+
+ QtiPlotApplication app( argc, argv );
+ app.connect( &app, SIGNAL(lastWindowClosed()), &app, SLOT(quit()) );
+
+--- qtiplot-0.9.8.9/qtiplot/qtiplot.pro 2011-11-02 17:55:25.000000000 +0100
+@@ -1,4 +1,3 @@
+-TARGET = qtiplot
+ QTI_ROOT = ..
+ !include( $$QTI_ROOT/build.conf ) {
+ message( "You need a build.conf file with local settings!" )
+@@ -14,12 +13,16 @@
+ INCLUDEPATH += $$QWT_INCLUDEPATH
+ INCLUDEPATH += $$QWT3D_INCLUDEPATH
+ INCLUDEPATH += $$GSL_INCLUDEPATH
++INCLUDEPATH += /usr/include/QtAssistant/
++INCLUDEPATH += /usr/include/python2.7
++
+
+ # configurable libs
+ LIBS += $$MUPARSER_LIBS
+ LIBS += $$QWT_LIBS
+ LIBS += $$QWT3D_LIBS
+ LIBS += $$GSL_LIBS
++LIBS += -lz -lGLU
+
+ #############################################################################
+ ###################### BASIC PROJECT PROPERTIES #############################
+@@ -46,7 +49,7 @@
+ unix:INSTALLS += man
+
+ unix: INSTALLBASE = /usr
+- win32: INSTALLBASE = C:/QtiPlot
++ win32: INSTALLBASE = C:/qtiplot-0.9.8.9
+
+ unix: target.path = $$INSTALLBASE/bin
+ unix: translations.path = $$INSTALLBASE/share/qtiplot/translations
+@@ -74,7 +77,6 @@
+ MOC_DIR = ../tmp/qtiplot
+ OBJECTS_DIR = ../tmp/qtiplot
+ SIP_DIR = ../tmp/qtiplot
+-DESTDIR = ./
+
+ #############################################################################
+ ###################### PROJECT FILES SECTION ################################
+@@ -159,7 +161,7 @@
+ qtiUtil.py \
+ qti_wordlist.txt \
+
+- unix: pythonconfig.path = /usr/local/qtiplot
++ unix: pythonconfig.path = /usr/share/qtiplot
+ win32: pythonconfig.path = $$INSTALLBASE
+ DEFINES += PYTHON_CONFIG_PATH="\\\"$$replace(pythonconfig.path," ","\ ")\\\"
+ }
+@@ -232,3 +234,13 @@
+ RC_FILE = qtiplot.rc
+ include(../3rdparty/QtSolutions/qtbrowserplugin/src/qtbrowserplugin.pri)
+ }
++
++###############################################################
++###############################################################
++###############################################################
++
++TARGET = qtiplot
++DESTDIR = .
++LIBS += ../tmp/qtiplot/libFreeSoftwareQtiPlotImportOPJ.a
++
++include(src/plugins/OriginPlugin/OriginPlugin.pri)
+\ No newline at end of file
+
+--- qtiplot-0.9.8.9/qtiplot.pro 2010-09-20 19:08:10.000000000 +0200
+@@ -1,7 +1,9 @@
+ TEMPLATE = subdirs
++CONFIG += ordered
+
+ SUBDIRS = fitPlugins \
+- manual \
+ 3rdparty/qwt \
+ 3rdparty/qwtplot3d \
+- qtiplot
++ 3rdparty/QTeXEngine \
++ qtiplot/importOPJ.pro \
++ qtiplot/qtiplot.pro
+
+--- qtiplot-0.9.8.9/3rdparty/qwt/qwtconfig.pri 2009-04-02 11:21:45.000000000 +0200
+@@ -15,9 +15,9 @@
+ INSTALLBASE = C:/Qwt-5.2.0
+ }
+
+-target.path = $$INSTALLBASE/lib
+-headers.path = $$INSTALLBASE/include
+-doc.path = $$INSTALLBASE/doc
++#target.path = $$INSTALLBASE/lib
++#headers.path = $$INSTALLBASE/include
++#doc.path = $$INSTALLBASE/doc
+
+ ######################################################################
+ # qmake internal options
+
+--- qtiplot-0.9.8.9/3rdparty/qwtplot3d/qwtplot3d.pro 2011-08-24 16:54:38.000000000 +0200
+@@ -36,5 +36,5 @@
+ LIBS += ../libpng/libpng.a
+
+ # install
+-target.path = lib
+-INSTALLS += target
++#target.path = lib
++#INSTALLS += target
+
+--- qtiplot-0.9.8.9/3rdparty/qwtplot3d/include/qwt3d_global.h 2011-08-24 17:25:09.000000000 +0700
+@@ -2,6 +2,7 @@
+ #define QWT3D_GLOBAL_H
+
+ #include <qglobal.h>
++#include <GL/glu.h>
+ #if QT_VERSION < 0x040000
+ #include <qmodules.h>
+ #endif
+
+--- qtiplot-0.9.8.9/3rdparty/qwtplot3d/3rdparty/gl2ps/gl2ps.c 2012-01-29 18:15:34.000000000 -0500
+@@ -47,6 +47,7 @@
+ #endif
+
+ #if defined(GL2PS_HAVE_LIBPNG)
++#include <zlib.h>
+ #include <png.h>
+ #endif
+
+
+--- qtiplot-0.9.8.9/3rdparty/qwtplot3d/include/qwt3d_io_gl2ps.h 2012-01-29 17:42:01.000000000 -0500
+@@ -2,12 +2,7 @@
+ #define qwt3d_io_gl2ps_h__2004_05_07_01_16_begin_guarded_code
+
+ #include <time.h>
+-
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL/QtOpenGL>
+
+ #include "qwt3d_types.h"
+ #include "qwt3d_io.h"
+
+--- qtiplot-0.9.8.9/3rdparty/qwtplot3d/include/qwt3d_openglhelper.h 2012-01-29 17:42:01.000000000 -0500
+@@ -2,11 +2,8 @@
+ #define __openglhelper_2003_06_06_15_49__
+
+ #include "qglobal.h"
+-#if QT_VERSION < 0x040000
+-#include <qgl.h>
+-#else
+-#include <QtOpenGL/qgl.h>
+-#endif
++#include <QtOpenGL/QtOpenGL>
++#include <GL/glu.h>
+
+ namespace Qwt3D
+ {
diff --git a/qtiplot.xml b/qtiplot.xml
new file mode 100755
index 000000000000..7ad4c4aa02ad
--- /dev/null
+++ b/qtiplot.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-qtiplot-project">
+ <sub-class-of type="text/plain"/>
+ <comment>QtiPlot project file</comment>
+ <glob pattern="*.qti" />
+ </mime-type>
+ <mime-type type="application/x-qtiplot-project-compressed">
+ <comment>Compressed QtiPlot project file</comment>
+ <glob pattern="*.qti.gz" />
+ </mime-type>
+ <mime-type type="application/x-qtiplot-project-backup">
+ <sub-class-of type="text/plain"/>
+ <comment>QtiPlot project file backup</comment>
+ <glob pattern="*.qti~" />
+ </mime-type>
+</mime-info>