summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2022-11-16 18:25:20 +0100
committerJens Staal2022-11-16 18:25:20 +0100
commit19b5a914f772ca5baf1e4fc1a8f36f11e390092d (patch)
treec7aeffff3d994712e4f881cd90d1c390b6842951
parent3d0f4a85d3492ea51b9116efb488962cb0380a13 (diff)
downloadaur-19b5a914f772ca5baf1e4fc1a8f36f11e390092d.tar.gz
removed .so copies and replaced with symlinks. Package reduced from 1073 MiB to 785 MiB
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 239eacaac74a..636c56055ccf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,16 +59,15 @@ package() {
cp LICENSE.* ${pkgdir}/usr/share/licenses/qtjambi/
#libraries get installed as copies instead of as symlinks. Fix up
+ _pkg2="$(echo ${pkgver} | cut -d. -f-2)"
+ _pkg1="$(echo ${pkgver} | cut -d. -f1)"
cd ${pkgdir}/usr/lib
- for i in {libQtJambi{,3D{Animation,Core,Extras,Input,Logic,Quick{,Extras,Scene2D},Render},Bluetooth,Charts,\
- Concurrent,Core,DBus,DataVisualization,Designer,Gui,Help,HttpServer,Multimedia{,Widgets},Network{,Auth},\
- Nfc,OpenGL,{,Widgets},Pdf{,Widgets},Positioning,PrintSupport,Qml,Quick{,3D,Controls2,Test,Widgets},\
- RemoteObjects,Scxml,Sensors,Serial{Bus,Port},SpatialAudio,Sql,StateMachine,Svg{,Widgets},Test,TextToSpeech,\
- UIC,UiTools,VirtualKeyboard,Web{Channel,Engine{Core,Quick,Widgets},Sockets,View},Widgets,Xml}; do
- for j in {${_pkg2},${_pkg1}}; do
- rm ${i}.so.${j}
- ln -s ${i}.so.${pkgver} ${i}.so.${j}
- done
+ for j in $(ls libQtJambi*.so.${pkgver}); do
+ k=$(echo ${j}| cut -d. -f-2)
+ rm ${k}.${_pkg1}
+ rm ${k}.${_pkg2}
+ ln -s ${j} ${k}.${_pkg1}
+ ln -s ${j} ${k}.${_pkg2}
done
#Hopefully will this ugly hack only be temporary...
}