summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2022-11-16 14:06:41 +0100
committerJens Staal2022-11-16 14:06:41 +0100
commit9021f0cbbf90d85c99cc0202070a76129303308a (patch)
treee972a1bf5b6f3812dc976f64c23b06f551574fbe
parent7eb9cfccf8dbac4ea7fb7c52ab314fdcfb54e2ec (diff)
downloadaur-9021f0cbbf90d85c99cc0202070a76129303308a.tar.gz
attempt at cleaning up /usr/lib from copies
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ddd91c53af..a9c70fc1d028 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtjambi
pkgdesc = QtJambi is Qt bindings for the Java programming language originally developed by Trolltech
pkgver = 6.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OmixVisualization/qtjambi
arch = x86_64
license = LGPL
@@ -11,6 +11,7 @@ pkgbase = qtjambi
depends = chrpath
depends = jdk-openjdk
depends = qt6-base
+ depends = qt6-remoteobjects
source = https://github.com/OmixVisualization/qtjambi/archive/refs/tags/v6.4.1.tar.gz
sha256sums = 280e9f49b11cfbe3fb5461e5a21f2c52aedd903596ea97ac312e1b3eeca4e90b
diff --git a/PKGBUILD b/PKGBUILD
index 270a4075e446..d66e84759ce8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Jens Staal <staal1978@gmail.com>
pkgname=qtjambi
pkgver=6.4.1
+_pkg2="$(echo ${pkgver} | cut -d. -f-2)"
+_pkg1="$(echo ${pkgver} | cut -d. -f1)"
##change these variables if needed##
_qtver=qt6
_javaver=19
####################################
-pkgrel=1
+pkgrel=2
pkgdesc="QtJambi is Qt bindings for the Java programming language originally developed by Trolltech"
arch=(x86_64)
url="https://github.com/OmixVisualization/qtjambi"
license=('LGPL' 'GPL')
-depends=('chrpath' 'jdk-openjdk' "${_qtver}-base")
+depends=('chrpath' 'jdk-openjdk' "${_qtver}-base" "${_qtver}-remoteobjects")
makedepends=('ant' 'apache-ant-contrib')
source=(https://github.com/OmixVisualization/qtjambi/archive/refs/tags/v${pkgver}.tar.gz)
sha256sums=(280e9f49b11cfbe3fb5461e5a21f2c52aedd903596ea97ac312e1b3eeca4e90b)
@@ -55,4 +57,18 @@ package() {
install ${pkgver}/deployment/native/linux-x64/release/utilities/QtJambiLauncher ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/share/licenses/qtjambi
cp LICENSE.* ${pkgdir}/usr/share/licenses/qtjambi/
+
+ #libraries get installed as copies instead of as symlinks. Fix up
+ cd ${pkgdir}/usr/lib
+ for i in {libQtJambi{,3D{Animation,Core,Extras,Input,Logic,Quick{,Extras,Scene2D},Render},Bluetooth,Charts,\
+ Concurrent,Core,DBus,DataVisualization,Designer,Gui,Help,HttpServer,Multimedia{,Widgets},Network{,Auth},\
+ Nfc,OpenGL,{,Widgets},Pdf{,Widgets},Positioning,PrintSupport,Qml,Quick{,3D,Controls2,Test,Widgets}.\
+ RemoteObjects,Scxml,Sensors,Serial{Bus,Port},SpatialAudio,Sql,StateMachine,Svg{,Widgets},Test,TextToSpeech,\
+ UIC,UiTools,VirtualKeyboard,Web{Channel,Engine{Core,Quick,Widgets},Sockets,View},Widgets,Xml}; do
+ for j in {${_pkg2},${_pkg1}}; do
+ rm ${i}.so.${j}
+ ln -s ${i}.so.${pkgver} ${i}.so.${j}
+ done
+ done
+ #Hopefully will this ugly hack only be temporary...
}