summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:35:31 -0700
committerShadowKyogre2015-06-08 07:35:31 -0700
commit8362b914ccff08fae1984cd8d4cd8d28f97f8fa6 (patch)
treeaf92087630362ca595d7e1285938955c2ba03552
downloadaur-8362b914ccff08fae1984cd8d4cd8d28f97f8fa6.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
-rw-r--r--gcc4.7fix.patch22
-rw-r--r--override_icon_theme.patch65
-rw-r--r--qtnotifydaemon.install3
5 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ba7f2f8f4d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = qtnotifydaemon
+ pkgdesc = Configurable and flexible Qt notification daemon
+ pkgver = 1.0.14
+ pkgrel = 4
+ url = http://sourceforge.net/projects/qtnotifydaemon
+ install = qtnotifydaemon.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ provides = notification-daemon
+ provides = xfce4-notifyd
+ provides = notify-osd
+ conflicts = notification-daemon
+ conflicts = xfce4-notifyd
+ conflicts = notify-osd
+ source = http://downloads.sourceforge.net/project/qtnotifydaemon/qtnotifydaemon_1.0.14.orig.tar.gz
+ source = override_icon_theme.patch
+ source = gcc4.7fix.patch
+ md5sums = af57385fb4acb48ce1ad40aaac369a4e
+ md5sums = cf6d30e755839eb05b5d63c6754a8524
+ md5sums = 70c283997217001b12ee7721d17491fc
+
+pkgname = qtnotifydaemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ded47899dcf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Sapphira Armageddos <shadowkyogre at aim dot com>
+#Contributor: Artem A Klevtsov <unikum.pm at gmail dot com>
+pkgname=qtnotifydaemon
+pkgver=1.0.14
+pkgrel=4
+pkgdesc="Configurable and flexible Qt notification daemon"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/${pkgname}"
+license=('GPL3')
+depends=('qt4')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
+"override_icon_theme.patch"
+'gcc4.7fix.patch')
+md5sums=('af57385fb4acb48ce1ad40aaac369a4e'
+ 'cf6d30e755839eb05b5d63c6754a8524'
+ '70c283997217001b12ee7721d17491fc')
+install="${pkgname}.install"
+conflicts=('notification-daemon' 'xfce4-notifyd' 'notify-osd')
+provides=('notification-daemon' 'xfce4-notifyd' 'notify-osd')
+
+build() {
+ cd ${srcdir}
+ patch -Ni ${srcdir}/override_icon_theme.patch
+ patch -Np1 -i ${srcdir}/gcc4.7fix.patch
+ qmake-qt4 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${srcdir}
+ install -Dm 755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm 644 org.freedesktop.Notifications.service ${pkgdir}/usr/share/dbus-1/services/org.freedesktop.Notifications.service
+ gzip debian/${pkgname}.1
+ install -Dm 644 debian/${pkgname}.1.gz ${pkgdir}/usr/share/man/man1/${pkgname}.1.gz
+}
diff --git a/gcc4.7fix.patch b/gcc4.7fix.patch
new file mode 100644
index 000000000000..5e216236d7a0
--- /dev/null
+++ b/gcc4.7fix.patch
@@ -0,0 +1,22 @@
+diff -aur src.cpy/main.cpp src.cpy2/main.cpp
+--- src.cpy/main.cpp 2012-06-05 12:32:37.554374898 -0700
++++ src.cpy2/main.cpp 2012-06-05 12:18:07.000000000 -0700
+@@ -26,6 +26,7 @@
+ #include "notifywidget.h"
+ #include "notifyarea.h"
+ #include <QDBusMessage>
++#include <unistd.h>
+
+ //alex: use qtbg, qtfg, border width (1 instead of 3) and other positions (bottom and top right) by default
+ char configcontent[1100]="\
+diff -aur src.cpy/notifyarea.cpp src.cpy2/notifyarea.cpp
+--- src.cpy/notifyarea.cpp 2012-06-05 12:32:33.677708039 -0700
++++ src.cpy2/notifyarea.cpp 2012-06-05 12:18:33.000000000 -0700
+@@ -25,6 +25,7 @@
+ #include "notifyarea.h"
+ #include "notifywidget.h"
+ #include "dbus.h"
++#include <unistd.h>
+
+ #include <X11/Xlib.h> //alex
+
diff --git a/override_icon_theme.patch b/override_icon_theme.patch
new file mode 100644
index 000000000000..1d4d14e3d125
--- /dev/null
+++ b/override_icon_theme.patch
@@ -0,0 +1,65 @@
+--- main.cpp 2011-08-16 03:37:09.000000000 -0700
++++ main2.cpp 2012-01-23 23:25:43.408546751 -0800
+@@ -28,7 +28,7 @@
+ #include <QDBusMessage>
+
+ //alex: use qtbg, qtfg, border width (1 instead of 3) and other positions (bottom and top right) by default
+-char configcontent[1024]="\
++char configcontent[1100]="\
+ #Widget style\n\
+ GeneralStyle = margin: 0px; background: qtbg; border: 1px solid qtfg; color: qtfg; border-radius: 15px; font-size: 14px;\n\
+ \n\
+@@ -44,7 +44,8 @@
+ #Opacity floating point value: 0-1\n\
+ Opacity = 0.8\n\
+ MaxIconSize = 80\n\
+-\n\
++#You should only set this if Qt isn't detecting the right icon theme to use\n\
++OverrideIconTheme = \n\
+ #Widgets position: \n\
+ # 0 (or BL) - bottomLeft\n\
+ # 1 (or BR) - bottomRight\n\
+
+--- notifyarea.cpp 2011-08-16 03:37:09.000000000 -0700
++++ notifyarea2.cpp 2012-01-23 23:09:44.603741043 -0800
+@@ -62,6 +62,18 @@
+ {
+ widgetStyle = "margin: 0px; background: black; border: 3px solid white; color: lime; border-radius: 15px;";
+ }
++iconOverride = this->readConfigString("OverrideIconTheme");
++if(iconOverride == NULL){
++ systemIcon = QIcon::themeName();
++}
++if(iconOverride!="")
++{
++ QIcon::setThemeName(iconOverride);
++}
++else
++{
++ QIcon::setThemeName(systemIcon);
++}
+ //alex:
+ if (widgetStyle.contains("qtfg") || widgetStyle.contains("qtbg"))
+ {
+
+--- notifyarea.h 2011-08-16 03:37:09.000000000 -0700
++++ notifyarea2.h 2012-01-23 23:06:20.588179625 -0800
+@@ -67,6 +67,8 @@
+ float maxOpacity;
+ int maxIconSize;
+ QString widgetStyle;
++QString iconOverride;
++QString systemIcon;
+ QString UrgencyTag[4];
+ QMyDBusAbstractAdaptor *adaptor;
+
+--- qtnotifydaemon.pro 2011-08-09 09:22:07.000000000 -0700
++++ qtnotifydaemon2.pro 2012-01-23 22:52:52.259225385 -0800
+@@ -8,6 +8,7 @@
+ DEPENDPATH += .
+ INCLUDEPATH += .
+ QT += dbus
++LIBS += -lX11
+ RESOURCES += images.qrc
+
+ # Input
diff --git a/qtnotifydaemon.install b/qtnotifydaemon.install
new file mode 100644
index 000000000000..244ba9e155b9
--- /dev/null
+++ b/qtnotifydaemon.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Default config file $HOME/.config/qtnotifydaemon/qtnotifydaemon.conf will appear after first launch."
+}