summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarat Moustafine2021-10-09 19:18:15 +0300
committerMarat Moustafine2021-10-09 19:18:36 +0300
commit84eb70cd5702b9ad7b6fb949991a01530b48989b (patch)
tree3bc7c76c35cc05be48d46803e2c9ec57236a9b02
parent1f47ff7451e6256bc664c80ef00ba4b231656f67 (diff)
downloadaur-qtools-git.tar.gz
Rename 'qteminal' to avoid the name conflict
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
-rw-r--r--rename-qterminal.patch22
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e87600c6269..ae7b58042252 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,8 +13,9 @@ pkgbase = qtools-git
backup = etc/qtools/chipset.cfg
source = git+https://github.com/forth32/qtools.git
source = chipconfig.patch
+ source = rename-qterminal.patch
sha256sums = SKIP
sha256sums = 618abb9acc929cdab9964a49254681bca07ffab088e283936501bfcdb5a881e4
+ sha256sums = b7d074976dc8191b8133d2bdc7cd20d850f08b868acfab0bc50e3b4eca8b5989
pkgname = qtools-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 70a972f7579f..119f8ef44eed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,11 @@ provides=($_pkgname)
conflicts=($_pkgname)
backup=(etc/$_pkgname/chipset.cfg)
source=(git+$url.git
- chipconfig.patch)
+ chipconfig.patch
+ rename-qterminal.patch)
sha256sums=('SKIP'
- '618abb9acc929cdab9964a49254681bca07ffab088e283936501bfcdb5a881e4')
+ '618abb9acc929cdab9964a49254681bca07ffab088e283936501bfcdb5a881e4'
+ 'b7d074976dc8191b8133d2bdc7cd20d850f08b868acfab0bc50e3b4eca8b5989')
pkgver() {
cd $_pkgname
@@ -30,6 +32,7 @@ pkgver() {
prepare() {
cd $_pkgname
patch -N -p 1 -i ../chipconfig.patch
+ patch -N -p 1 -i ../rename-qterminal.patch
}
build () {
@@ -51,7 +54,7 @@ package() {
qnvram \
qrflash \
qrmem \
- qterminal \
+ qterm \
qwdirect \
qwflash
install -D -m 644 -t $pkgdir/usr/lib/$_pkgname/loaders loaders/*.bin
diff --git a/rename-qterminal.patch b/rename-qterminal.patch
new file mode 100644
index 000000000000..c27e42fba5ae
--- /dev/null
+++ b/rename-qterminal.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 50f8408..3c0be7c 100755
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@ OBJS = hdlc.o qcio.o memio.o chipconfig.o
+
+ .PHONY: all clean
+
+-all: qcommand qrmem qrflash qdload mibibsplit qwflash qwdirect qefs qnvram qblinfo qident qterminal qbadblock qflashparm
++all: qcommand qrmem qrflash qdload mibibsplit qwflash qwdirect qefs qnvram qblinfo qident qterm qbadblock qflashparm
+
+ clean:
+ rm *.o
+@@ -59,7 +59,7 @@ qblinfo: qblinfo.o $(OBJS)
+ qident: qident.o $(OBJS)
+ gcc $^ -o $@ $(LIBS)
+
+-qterminal: qterminal.o $(OBJS)
++qterm: qterminal.o $(OBJS)
+ gcc $^ -o $@ $(LIBS)
+
+ qbadblock: qbadblock.o $(OBJS) ptable.o