summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2016-04-12 22:33:16 +0300
committervlad2016-04-12 22:33:16 +0300
commit196b57d6c5015cca813d3dfca98b683ad2f6ca51 (patch)
tree95478a969e51b0d505b71224c6595f5d217883ec
parent513269aa46bef645fdbc2ed0d9924661709d4870 (diff)
downloadaur-196b57d6c5015cca813d3dfca98b683ad2f6ca51.tar.gz
update to 1.3.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d31e670e26..90f3327b9fdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 27 17:24:10 UTC 2016
+# Tue Apr 12 19:32:55 UTC 2016
pkgbase = qtox-git
pkgdesc = Powerful Tox client written in C++/Qt that follows the Tox design guidelines.
- pkgver = 1.2.r321.ga3802bd
+ pkgver = 1.3.0.r170.g0a2f541
pkgrel = 1
url = https://github.com/tux3/qTox
install = qtox-git.install
@@ -15,11 +15,10 @@ pkgbase = qtox-git
makedepends = git
makedepends = qt5-tools
depends = desktop-file-utils
- depends = libfilteraudio-git
- depends = libxkbcommon-x11
+ depends = gtk2
depends = libxss
depends = openal
- depends = opencv
+ depends = ffmpeg
depends = qrencode
depends = qt5-svg
depends = sqlcipher
diff --git a/PKGBUILD b/PKGBUILD
index 768a447b005c..b6045225e7ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@
_pkgname=qtox
pkgname=qtox-git
-pkgver=1.2.r321.ga3802bd
+pkgver=1.3.0.r170.g0a2f541
pkgrel=1
pkgdesc='Powerful Tox client written in C++/Qt that follows the Tox design guidelines.'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url='https://github.com/tux3/qTox'
license=('GPL3')
depends=('desktop-file-utils'
- 'libfilteraudio-git'
- 'libxkbcommon-x11'
+ 'gtk2'
'libxss'
'openal'
- 'opencv'
+ 'ffmpeg'
'qrencode'
'qt5-svg'
'sqlcipher'
@@ -35,23 +34,11 @@ build() {
cd $_pkgname
install -d build
cd build
- qmake-qt5 ENABLE_SYSTRAY_UNITY_BACKEND=NO ..
+ qmake-qt5 ENABLE_SYSTRAY_UNITY_BACKEND=NO CONFIG+=silent ..
make
}
package() {
- # executable
- cd $_pkgname
- install -Dm755 build/$_pkgname "$pkgdir/usr/bin/$_pkgname"
-
- # xdg desktop file
- install -Dm644 qTox.desktop "$pkgdir/usr/share/applications/qTox.desktop"
-
- # icons
- cd img/icons
- for _icon in *.png; do
- _size=$(sed 's|^[^-]*-||;s|\.png||' <<< "$_icon")
- install -Dm644 "$_icon" "$pkgdir/usr/share/icons/hicolor/$_size/apps/qTox.png"
- done
- install -Dm644 $_pkgname.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/qTox.svg"
+ cd $_pkgname/build
+ make INSTALL_ROOT="$pkgdir" install
}