summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis Ben Miloud--Josselin2023-08-26 22:03:32 +0200
committerAlexis Ben Miloud--Josselin2023-08-26 22:22:41 +0200
commit48da60679e182b54fb5360c2c74718c4cc36defe (patch)
tree8ce75ac65e1de685f066ec1d62d907a5210e9c6d
parent0266e97a1646f8fe4cbb7103efd7a9e59d7c5892 (diff)
downloadaur-48da60679e182b54fb5360c2c74718c4cc36defe.tar.gz
Add VST3 SDK submodules
The package won't build without them. VST3 SDK is included as submodules since 4c76d9d. The vst3sdk dependency is not needed anymore.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f6edb348dcc..570d14c0e7d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtractor-git
pkgdesc = Audio/MIDI multitrack sequencer
- pkgver = 0.9.34.r17.g73d233f1
+ pkgver = 0.9.34.r21.g5f5d0980
pkgrel = 1
url = https://qtractor.org/
arch = x86_64
@@ -43,6 +43,12 @@ pkgbase = qtractor-git
provides = vst3-host
conflicts = qtractor
source = qtractor::git+https://github.com/rncbc/qtractor.git
+ source = git+https://github.com/steinbergmedia/vst3_base.git
+ source = git+https://github.com/steinbergmedia/vst3_pluginterfaces.git
+ source = git+https://github.com/steinbergmedia/vst3_public_sdk.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = qtractor-git
diff --git a/PKGBUILD b/PKGBUILD
index f201030296d6..562e24827688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
pkgname=qtractor-git
-pkgver=0.9.34.r17.g73d233f1
+pkgver=0.9.34.r21.g5f5d0980
pkgrel=1
pkgdesc="Audio/MIDI multitrack sequencer"
arch=('x86_64')
@@ -14,15 +14,30 @@ license=('GPL2')
groups=('pro-audio')
depends=(glibc gcc-libs hicolor-icon-theme libmad libxcb qt6-base qt6-svg zlib)
makedepends=(alsa-lib aubio clap cmake dssi git jack ladspa liblo libogg libsamplerate
-libsndfile libvorbis lilv lv2 qt6-tools rubberband suil vst3sdk)
+libsndfile libvorbis lilv lv2 qt6-tools rubberband suil)
optdepends=(
'new-session-manager: for session management'
'qt6-wayland: for native wayland support'
)
provides=(clap-host dssi-host ladspa-host lv2-host vst-host vst3-host)
conflicts=(qtractor)
-source=("${pkgname%-*}::git+https://github.com/rncbc/qtractor.git")
-md5sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/rncbc/qtractor.git"
+ "git+https://github.com/steinbergmedia/vst3_base.git"
+ "git+https://github.com/steinbergmedia/vst3_pluginterfaces.git"
+ "git+https://github.com/steinbergmedia/vst3_public_sdk.git")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd qtractor
+ git submodule init
+ git config submodule.src/vst3/base.url "${srcdir}/vst3_base"
+ git config submodule.src/vst3/pluginterfaces.url "${srcdir}/vst3_pluginterfaces"
+ git config submodule.src/vst3/public.sdk.url "${srcdir}/vst3_public_sdk"
+ git -c protocol.file.allow=always submodule update
+}
pkgver() {
cd "${srcdir}/${pkgname%-*}"
@@ -47,5 +62,5 @@ package() {
make DESTDIR="${pkgdir}" install -C build
# docs
- install -vDm 644 "qtractor/"{README,README.VST,README.VST3} -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -vDm 644 "qtractor/"{README,README.VST} -t "${pkgdir}/usr/share/doc/${pkgname}"
}