summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2015-06-15 13:07:06 -0500
committerGötz Christ2015-06-15 13:07:06 -0500
commit9112bb35070f76a8c8f5dc64c284d6e051ae5fa6 (patch)
tree455aee6c701fcd5be283e04cbcf2a2e62f0cd835
downloadaur-9112bb35070f76a8c8f5dc64c284d6e051ae5fa6.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
-rw-r--r--qtResistors.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aaf840bff56a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qtresistors
+ pkgdesc = Calculate resistance value and tolerance of resistors by their color codes.
+ pkgver = 0.1.3
+ pkgrel = 2
+ url = https://github.com/goetzc/qtResistors
+ install = qtResistors.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = libxkbcommon-x11
+ source = https://github.com/goetzc/qtResistors/archive/0.1.3.tar.gz
+ sha256sums = 806982cd62f7ac29f71141e318acbd79791aa279697d04226cfb8109647e838d
+
+pkgname = qtresistors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf5708ac0045
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=qtresistors
+pkgver=0.1.3
+pkgrel=2
+pkgdesc="Calculate resistance value and tolerance of resistors by their color codes."
+arch=('i686' 'x86_64')
+url="https://github.com/goetzc/qtResistors"
+#url="http://qt-apps.org/content/show.php/qtResistors?content=118297"
+license=('GPL')
+depends=('qt5-base' 'libxkbcommon-x11')
+install='qtResistors.install'
+source=("https://github.com/goetzc/qtResistors/archive/$pkgver.tar.gz")
+sha256sums=('806982cd62f7ac29f71141e318acbd79791aa279697d04226cfb8109647e838d')
+
+# To build using Qt 4, change to 1
+_Qt4=0
+[ "$_Qt4" = '1' ] && depends=('qt4')
+
+build() {
+ cd qtResistors-$pkgver/src
+
+ if [ "$_Qt4" = '0' ]; then
+ qmake-qt5
+ elif [ "$_Qt4" = '1' ]; then
+ qmake-qt4
+ else
+ qmake
+ fi
+
+ make
+}
+
+package() {
+ cd qtResistors-$pkgver
+
+ install -Dm755 src/qtResistors $pkgdir/usr/bin/qtResistors
+ install -Dm644 qtResistors.desktop $pkgdir/usr/share/applications/qtResistors.desktop
+ install -Dm644 icons/qtResistors.png $pkgdir/usr/share/icons/hicolor/64x64/apps/qtResistors.png
+}
diff --git a/qtResistors.install b/qtResistors.install
new file mode 100644
index 000000000000..6481cee07145
--- /dev/null
+++ b/qtResistors.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}