summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Mori2019-09-03 12:01:37 +0200
committerNicola Mori2019-09-03 12:01:37 +0200
commit3a5fd8711227d25db350f6880bf1ed1722f5b6c6 (patch)
tree2a8a50407f8c6ffb3a8189e5ebf7c71ca2519087
downloadaur-3a5fd8711227d25db350f6880bf1ed1722f5b6c6.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e188eaf44ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qtscriptbindings
+ pkgdesc = Qt bindings for Qt script (extracted from qcad)
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/qcad/qcad
+ arch = x86_64
+ license = GPLv3
+ depends = qt5-base
+ depends = qt5-script
+ depends = qt5-svg
+ depends = qt5-xmlpatterns
+ depends = qt5-tools
+ source = https://github.com/qcad/qcad/archive/v3.23.0.0.zip
+ md5sums = 026e8e2dd1be0cd0331deb2bd096a11c
+
+pkgname = qtscriptbindings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b04359220f4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nicola Mori <nicolamori (at) aol (dot) com>
+
+pkgname=qtscriptbindings
+pkgver=0.1
+pkgrel=1
+pkgdesc="Qt bindings for Qt script (extracted from qcad)"
+arch=('x86_64')
+url="https://github.com/qcad/qcad"
+license=('GPLv3')
+depends=('qt5-base' 'qt5-script' 'qt5-svg' 'qt5-xmlpatterns' 'qt5-tools')
+source=("https://github.com/qcad/qcad/archive/v3.23.0.0.zip")
+md5sums=('026e8e2dd1be0cd0331deb2bd096a11c')
+
+build() {
+
+ cd qcad-3.23.0.0/src/3rdparty/qt-labs-qtscriptgenerator-5.5.0/
+ qmake
+ make
+
+}
+
+package() {
+
+ mkdir -p ${pkgdir}/usr/lib/qt/plugins/script
+ install ${srcdir}/qcad-3.23.0.0/plugins/script/* ${pkgdir}/usr/lib/qt/plugins/script
+
+}