summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-07-19 12:48:48 +0200
committerLuca Weiss2016-07-19 12:48:48 +0200
commit517e392fc8508c63d254ea4d02b3e576c33e0776 (patch)
treee21867a0bf320cf39a358a73ea89de43cd1c4d7c
parentbe7f580313c20c862c8b3b46ab12fdc0d7144717 (diff)
downloadaur-517e392fc8508c63d254ea4d02b3e576c33e0776.tar.gz
Formatting and more
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf75b810fd9..96cbff9b66f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue May 3 08:41:31 UTC 2016
+# Tue Jul 19 10:48:41 UTC 2016
pkgbase = qtshutdownmenu-git
pkgdesc = Graphical shutdown util with PyQt5 and lock script for i3
pkgver = r4.314f35e
@@ -7,6 +7,7 @@ pkgbase = qtshutdownmenu-git
url = https://github.com/z3ntu/qtshutdownmenu
arch = any
license = MIT
+ makedepends = git
depends = python
depends = python-pyqt5
depends = ttf-liberation
diff --git a/PKGBUILD b/PKGBUILD
index d09df32926fd..086fd8f903f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+
pkgname=qtshutdownmenu-git
pkgver=r4.314f35e
pkgrel=1
@@ -6,6 +7,7 @@ pkgdesc="Graphical shutdown util with PyQt5 and lock script for i3"
arch=('any')
url="https://github.com/z3ntu/qtshutdownmenu"
license=('MIT')
+makedepends=('git')
depends=('python' 'python-pyqt5' 'ttf-liberation' 'imagemagick' 'scrot' 'i3lock')
options=(!emptydirs)
source=(git+https://github.com/z3ntu/qtshutdownmenu)
@@ -20,10 +22,11 @@ package() {
cd "$srcdir/qtshutdownmenu"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/icons"
- mkdir -p "$pkdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/applications"
install -Dm755 "shutdownmenu.py" "$pkgdir/usr/bin/qtshutdownmenu"
install -Dm755 "lock.sh" "$pkgdir/usr/bin/lock"
install -Dm755 "icon.png" "$pkgdir/usr/share/icons/lock.png"
install -Dm755 "qtshutdownmenu.desktop" "$pkgdir/usr/share/applications/qtshutdownmenu.desktop"
}
+# vim:set ts=2 sw=2 et: