summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-05-03 10:32:42 +0200
committerLuca Weiss2016-05-03 10:32:42 +0200
commit6b88c6a421a25f9f71fdf065ee708f609f167322 (patch)
tree05787642657cb52fc2dffefc21293c55a64e6115
downloadaur-6b88c6a421a25f9f71fdf065ee708f609f167322.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf4edf64007e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue May 3 08:32:33 UTC 2016
+pkgbase = qtshutdownmenu-git
+ pkgdesc = Graphical shutdown util with PyQt5 and lock script for i3
+ pkgver = r3.c08b4f7
+ pkgrel = 1
+ url = https://github.com/z3ntu/qtshutdownmenu
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pyqt5
+ depends = ttf-liberation
+ depends = imagemagick
+ depends = scrot
+ depends = i3lock
+ options = !emptydirs
+ source = git+https://github.com/z3ntu/qtshutdownmenu
+ md5sums = SKIP
+
+pkgname = qtshutdownmenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..462ff9ae7592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+pkgname=qtshutdownmenu-git
+pkgver=r3.c08b4f7
+pkgrel=1
+pkgdesc="Graphical shutdown util with PyQt5 and lock script for i3"
+arch=('any')
+url="https://github.com/z3ntu/qtshutdownmenu"
+license=('MIT')
+depends=('python' 'python-pyqt5' 'ttf-liberation' 'imagemagick' 'scrot' 'i3lock')
+options=(!emptydirs)
+source=(git+https://github.com/z3ntu/qtshutdownmenu)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/qtshutdownmenu"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/qtshutdownmenu"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/icons"
+ install -Dm755 "shutdownmenu.py" "$pkgdir/usr/bin/qtshutdownmenu"
+ install -Dm755 "lock.sh" "$pkgdir/usr/bin/lock"
+ install -Dm755 "icon.png" "$pkgdir/usr/share/icons/lock.png"
+}
+