summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBowDown0972023-03-05 21:32:01 -0800
committerBowDown0972023-03-05 21:32:01 -0800
commit8f613cf2d85277f956bc36d0891f6c21a5bb33ea (patch)
treec71f1b0d11d7e6a6ddf318ce679cfd59dcb77b59
downloadaur-8f613cf2d85277f956bc36d0891f6c21a5bb33ea.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dcd5e31ec1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = qttube-git
+ pkgdesc = A Qt frontend for YouTube.
+ pkgver = 350fd78
+ pkgrel = 1
+ url = https://github.com/BowDown097/QtTube
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ depends = openssl
+ depends = qt6-base
+ depends = qt6-webchannel
+ depends = qt6-webengine
+ optdepends = libxss: for preventing the screen from sleeping while watching videos
+ provides = qttube
+ conflicts = qttube
+ source = git+https://github.com/BowDown097/QtTube
+ source = git+https://github.com/BowDown097/innertube-qt
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = qttube-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..478f9597af70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: BowDown097 <bowdown097 at sneed dot church>
+
+_pkgname=qttube
+pkgname=${_pkgname}-git
+pkgver=350fd78
+pkgrel=1
+pkgdesc="A Qt frontend for YouTube."
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/BowDown097/QtTube"
+license=('GPL3')
+depends=('openssl' 'qt6-base' 'qt6-webchannel' 'qt6-webengine')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+makedepends=('git')
+optdepends=('libxss: for preventing the screen from sleeping while watching videos')
+source=("git+https://github.com/BowDown097/QtTube"
+ "git+https://github.com/BowDown097/innertube-qt")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/QtTube"
+ git rev-parse --short HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "QtTube"
+ git submodule init
+ git config submodule.depends/innertube-qt.url "${srcdir}/innertube-qt"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${srcdir}/QtTube"
+ mkdir build
+ cd build
+ qmake6 ..
+ make
+}
+
+package() {
+ cd "${srcdir}/QtTube"
+ cd build
+ make INSTALL_ROOT="${pkgdir}" install
+
+ cd ..
+ install -Dm644 "program_info/qttube.desktop" "$pkgdir/usr/share/applications/qttube.desktop"
+ install -Dm644 "res/qttube.svg" "$pkgdir/usr/share/pixmaps/qttube.svg"
+}