summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-09-26 17:36:20 +0200
committerMartchus2018-09-26 17:36:20 +0200
commit0efdd862dcf0db07a19675ef7edd7da3b8b25b95 (patch)
treea70c91bcf1c971afc8dfbc80f87d693faa06d63b
parenteedc4facbba5ff674f00da5a3b86c841eabb86c9 (diff)
downloadaur-0efdd862dcf0db07a19675ef7edd7da3b8b25b95.tar.gz
Update version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a19b35c93082..66589982ee8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = qtutilities
pkgdesc = Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models
- pkgver = 5.10.0
- pkgrel = 2
+ pkgver = 5.11.0
+ pkgrel = 1
url = https://github.com/Martchus/qtutilities
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = qt5-tools
+ makedepends = mesa
depends = c++utilities
depends = qt5-base
optdepends = qtutilities-doc: API documentation
- source = qtutilities-5.10.0.tar.gz::https://github.com/Martchus/qtutilities/archive/v5.10.0.tar.gz
- source = 0001-Fix-missing-includes.patch::https://github.com/Martchus/qtutilities/commit/571c2f8a268cf1382bc66d3783a2cc6977c53955.patch
- sha256sums = b0330de29dbf4878f2681417c6b632a98a04369134998cff1f34a4377fe1493f
- sha256sums = f4e1c23b92b89dbd105a9bcbb0cb38b4776ebcb381543508300831348f94d4c0
+ source = qtutilities-5.11.0.tar.gz::https://github.com/Martchus/qtutilities/archive/v5.11.0.tar.gz
+ sha256sums = ebbb5b3b17fdfda83bc23e51feffd7319e242542d116e45bcda6de9221f428fc
pkgname = qtutilities
diff --git a/PKGBUILD b/PKGBUILD
index c9a13b08e564..930a62e21724 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,17 @@
_reponame=qtutilities
pkgname=qtutilities
-pkgver=5.10.0
-pkgrel=2
+pkgver=5.11.0
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models'
license=('GPL')
depends=('c++utilities' 'qt5-base')
-makedepends=('cmake' 'qt5-tools')
+makedepends=('cmake' 'qt5-tools' 'mesa')
optdepends=("$pkgname-doc: API documentation")
url="https://github.com/Martchus/${_reponame}"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
- "0001-Fix-missing-includes.patch::https://github.com/Martchus/${_reponame}/commit/571c2f8a268cf1382bc66d3783a2cc6977c53955.patch")
-sha256sums=('b0330de29dbf4878f2681417c6b632a98a04369134998cff1f34a4377fe1493f'
- 'f4e1c23b92b89dbd105a9bcbb0cb38b4776ebcb381543508300831348f94d4c0')
-
-prepare() {
- cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- patch -Np1 -i "$srcdir/0001-Fix-missing-includes.patch"
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('ebbb5b3b17fdfda83bc23e51feffd7319e242542d116e45bcda6de9221f428fc')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"