summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-04-26 21:52:47 +0200
committerMartchus2016-04-26 21:52:47 +0200
commit6992e82d7aae1e28057cd8407738292f174208ca (patch)
tree810fcb6ad35c63e200ef493ff30c9bac373e84de
parent4795286cac2493bb0830c5708cb9e3fccf95b3ed (diff)
downloadaur-6992e82d7aae1e28057cd8407738292f174208ca.tar.gz
mingw-w64-qtutilities
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5ea5a391ef4..cc52f320c7c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 27 22:04:56 UTC 2015
+# Tue Apr 26 19:52:47 UTC 2016
pkgbase = qtutilities
pkgdesc = Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models.
- pkgver = 3.1.0
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/Martchus/qtutilities
arch = i686
@@ -11,8 +11,8 @@ pkgbase = qtutilities
makedepends = cmake
depends = c++utilities
depends = qt5-base
- source = qtutilities-3.1.0.tar.gz::https://github.com/Martchus/qtutilities/archive/v3.1.0.tar.gz
- sha256sums = e2c9816aa82ea98004437503b52b4b64cec56fc7fd4bd2a649d998a2d1a2cf8d
+ source = qtutilities-4.0.0.tar.gz::https://github.com/Martchus/qtutilities/archive/v4.0.0.tar.gz
+ sha256sums = 7213b676b3b2ed1d92ffccf7cb8ebd234a5bb6d7194646143d5dc295030eca5f
pkgname = qtutilities
diff --git a/PKGBUILD b/PKGBUILD
index 797ae9b9aa8d..4bc38a84a189 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,11 @@
# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_reponame=qtutilities
pkgname=qtutilities
-pkgver=3.1.0
+pkgver=4.0.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models."
@@ -10,16 +14,15 @@ depends=('c++utilities' 'qt5-base')
makedepends=('cmake')
url="https://github.com/Martchus/${_reponame}"
source=("qtutilities-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('e2c9816aa82ea98004437503b52b4b64cec56fc7fd4bd2a649d998a2d1a2cf8d')
+sha256sums=('7213b676b3b2ed1d92ffccf7cb8ebd234a5bb6d7194646143d5dc295030eca5f')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr"
make
}
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- make install
+ make DESTDIR="${pkgdir}" install
}
-