summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-06-05 22:57:51 +0200
committerMartchus2018-06-05 22:57:51 +0200
commiteedc4facbba5ff674f00da5a3b86c841eabb86c9 (patch)
treefc11ec1457c2ce9ee61ddd5aa9acc3af04d6d7e4
parent64d5c001baa87b189f8a36677e52bc36b5cfb615 (diff)
downloadaur-eedc4facbba5ff674f00da5a3b86c841eabb86c9.tar.gz
Rebuild against Qt 5.11.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed9a24f8aa3..a19b35c93082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtutilities
pkgdesc = Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models
pkgver = 5.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Martchus/qtutilities
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = qtutilities
depends = qt5-base
optdepends = qtutilities-doc: API documentation
source = qtutilities-5.10.0.tar.gz::https://github.com/Martchus/qtutilities/archive/v5.10.0.tar.gz
+ source = 0001-Fix-missing-includes.patch::https://github.com/Martchus/qtutilities/commit/571c2f8a268cf1382bc66d3783a2cc6977c53955.patch
sha256sums = b0330de29dbf4878f2681417c6b632a98a04369134998cff1f34a4377fe1493f
+ sha256sums = f4e1c23b92b89dbd105a9bcbb0cb38b4776ebcb381543508300831348f94d4c0
pkgname = qtutilities
diff --git a/PKGBUILD b/PKGBUILD
index 48097c8adcf5..c9a13b08e564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_reponame=qtutilities
pkgname=qtutilities
pkgver=5.10.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models'
license=('GPL')
@@ -14,8 +14,15 @@ depends=('c++utilities' 'qt5-base')
makedepends=('cmake' 'qt5-tools')
optdepends=("$pkgname-doc: API documentation")
url="https://github.com/Martchus/${_reponame}"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('b0330de29dbf4878f2681417c6b632a98a04369134998cff1f34a4377fe1493f')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
+ "0001-Fix-missing-includes.patch::https://github.com/Martchus/${_reponame}/commit/571c2f8a268cf1382bc66d3783a2cc6977c53955.patch")
+sha256sums=('b0330de29dbf4878f2681417c6b632a98a04369134998cff1f34a4377fe1493f'
+ 'f4e1c23b92b89dbd105a9bcbb0cb38b4776ebcb381543508300831348f94d4c0')
+
+prepare() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ patch -Np1 -i "$srcdir/0001-Fix-missing-includes.patch"
+}
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"