summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-24 10:00:20 +0800
committerzxp198210052023-10-24 10:00:20 +0800
commitad8d1a36f43818d5f81dd099543971f204fece21 (patch)
tree1a51d4c62b9fde6fa23f783963c46f914acd544e
parent60ca269514dd8fd3cd973d3f3235b49a657c0e70 (diff)
downloadaur-ad8d1a36f43818d5f81dd099543971f204fece21.tar.gz
update to 1.0.52-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fee6d77b43e1..03b0d7a2a5c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtvsplayer-bin
pkgdesc = QtVsPlayer for Hikvision, QtVsPlayer can read local video files of Hikvision and display blue, green and red vector.It read real time live stream
- pkgver = 1.0.51_3
- pkgrel = 2
+ pkgver = 1.0.52_1
+ pkgrel = 1
url = https://github.com/surfzoid/QtVsPlayer
arch = aarch64
arch = x86_64
@@ -17,9 +17,9 @@ pkgbase = qtvsplayer-bin
depends = openal
depends = openssl-1.1
conflicts = qtvsplayer
- source_aarch64 = qtvsplayer-1.0.51_3-aarch64.deb::https://github.com/surfzoid/QtVsPlayer/releases/download/1.0.51-3/QtVsPlayer_1.0.51-3_bullseye-arm64.deb
- sha256sums_aarch64 = 9831ed2ca84c2d36920f19f821c8586a0c407e30d7c16b61674b78f0997ea7bf
- source_x86_64 = qtvsplayer-1.0.51_3-x86_64.deb::https://github.com/surfzoid/QtVsPlayer/releases/download/1.0.51-3/QtVsPlayer_1.0.51-3_ubuntu-latest-amd64.deb
- sha256sums_x86_64 = 01de6b381b38829190ef684da106da0d45c343edc43cd35819d6190e5052eb47
+ source_aarch64 = qtvsplayer-1.0.52_1-aarch64.deb::https://github.com/surfzoid/QtVsPlayer/releases/download/1.0.52-1/QtVsPlayer_1.0.52-1_bullseye-arm64.deb
+ sha256sums_aarch64 = a8040dc4af3920829ce5f86880f32fa57dac836def528209f8264e21e7e4fca3
+ source_x86_64 = qtvsplayer-1.0.52_1-x86_64.deb::https://github.com/surfzoid/QtVsPlayer/releases/download/1.0.52-1/QtVsPlayer_1.0.52-1_ubuntu-latest-amd64.deb
+ sha256sums_x86_64 = 2361f785132b356a061391eee5600781be964d9383ddd7819f20ac907d29d909
pkgname = qtvsplayer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 18d6edeaa68c..ad88352f69e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=qtvsplayer-bin
_pkgname=QtVsPlayer
-pkgver=1.0.51_3
-pkgrel=2
+pkgver=1.0.52_1
+pkgrel=1
pkgdesc="QtVsPlayer for Hikvision, QtVsPlayer can read local video files of Hikvision and display blue, green and red vector.It read real time live stream"
arch=('aarch64' 'x86_64')
url="https://github.com/surfzoid/QtVsPlayer"
@@ -11,8 +11,8 @@ depends=('freetype2' 'zlib' 'util-linux-libs' 'glibc' 'qt5-base' 'libx11' 'libgl
conflicts=("${pkgname%-bin}")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${url}/releases/download/${pkgver//_/-}/${_pkgname}_${pkgver//_/-}_bullseye-arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${url}/releases/download/${pkgver//_/-}/${_pkgname}_${pkgver//_/-}_ubuntu-latest-amd64.deb")
-sha256sums_aarch64=('9831ed2ca84c2d36920f19f821c8586a0c407e30d7c16b61674b78f0997ea7bf')
-sha256sums_x86_64=('01de6b381b38829190ef684da106da0d45c343edc43cd35819d6190e5052eb47')
+sha256sums_aarch64=('a8040dc4af3920829ce5f86880f32fa57dac836def528209f8264e21e7e4fca3')
+sha256sums_x86_64=('2361f785132b356a061391eee5600781be964d9383ddd7819f20ac907d29d909')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/usr/bin/${_pkgname}|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g;s|/usr/bin|/opt/${pkgname%-bin}|g" \
@@ -22,7 +22,7 @@ build() {
}
package() {
install -Dm755 "${srcdir}/usr/bin/${_pkgname}" -t "${pkgdir}/opt/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-bin}.conf" -t "${pkgdir}//etc/ld.so.conf.d"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.conf" -t "${pkgdir}/etc/ld.so.conf.d"
cp -r "${srcdir}/usr/lib64/${_pkgname}/"* "${pkgdir}/opt/${pkgname%-bin}"
install -Dm755 -d "${pkgdir}/usr/bin"
ln -sf "/opt/${pkgname%-bin}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"