summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2017-02-20 16:28:32 +0100
committerFrederic Bezies2017-02-20 16:28:32 +0100
commit85c4169dab92f7eba5fda158f8df00e47612f9ac (patch)
treed1e3f06dedc124d16aa4c9e9975cdfc9c4d2fc99
parent35546e13ae3eb57edadd5572fe65fbb7d5886c25 (diff)
downloadaur-85c4169dab92f7eba5fda158f8df00e47612f9ac.tar.gz
adding patch to fix metak build bug
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--fix-build-in-usr.patch10
3 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5af34d4098b..3886427abea5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Feb 20 15:28:02 UTC 2017
pkgbase = qtwebkit
pkgdesc = An open source web browser engine (Qt port)
pkgver = 2.3.4
- pkgrel = 4
+ pkgrel = 5
url = http://trac.webkit.org/wiki/QtWebKit
arch = i686
arch = x86_64
@@ -21,11 +23,13 @@ pkgbase = qtwebkit
source = use-python2.patch
source = qwebview.patch
source = gcc-5.patch
+ source = fix-build-in-usr.patch
sha1sums = 31bc60de1cf26bb0766d539b4d564651ddbb0650
sha1sums = 76aef40335c0701e5be7bb3a9101df5d22fe3666
sha1sums = 315b6ff603f35e5492a036f7082f6aa075dfb607
sha1sums = c3df6107233f466a032e36681cee07f16536657c
sha1sums = 5d506578ea30daeeeb1e91ab83876fe6d5669715
+ sha1sums = 412a58db507fa14268c9f30627d62fd448f9dccb
pkgname = qtwebkit
diff --git a/PKGBUILD b/PKGBUILD
index 51abafc98a6e..04990c18394b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=qtwebkit
pkgver=2.3.4
-pkgrel=4
+pkgrel=5
arch=('i686' 'x86_64')
url='http://trac.webkit.org/wiki/QtWebKit'
pkgdesc='An open source web browser engine (Qt port)'
@@ -15,7 +15,7 @@ _qtver=4.8.7
source=("https://sources.archlinux.org/other/packages/${pkgname}/${pkgname}-${pkgver}.tar.xz"
"http://download.qt-project.org/official_releases/qt/4.8/${_qtver}/qt-everywhere-opensource-src-${_qtver}.tar.gz"
'use-python2.patch'
- 'qwebview.patch' 'gcc-5.patch')
+ 'qwebview.patch' 'gcc-5.patch' 'fix-build-in-usr.patch')
sha1sums=('31bc60de1cf26bb0766d539b4d564651ddbb0650'
'76aef40335c0701e5be7bb3a9101df5d22fe3666'
'315b6ff603f35e5492a036f7082f6aa075dfb607'
@@ -25,6 +25,7 @@ sha1sums=('31bc60de1cf26bb0766d539b4d564651ddbb0650'
prepare() {
cd ${pkgname}-${pkgver}
patch -p1 -i "${srcdir}"/use-python2.patch
+ patch -p1 -i "${srcdir}"/fix-build-in-usr.patch
# Fix build with GCC 5 (Fedora)
patch -p1 -i "$srcdir"/gcc-5.patch
@@ -68,3 +69,9 @@ package() {
# Fix wrong path in prl file
sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' "${pkgdir}"/usr/lib/libQtWebKit.prl
}
+sha1sums=('31bc60de1cf26bb0766d539b4d564651ddbb0650'
+ '76aef40335c0701e5be7bb3a9101df5d22fe3666'
+ '315b6ff603f35e5492a036f7082f6aa075dfb607'
+ 'c3df6107233f466a032e36681cee07f16536657c'
+ '5d506578ea30daeeeb1e91ab83876fe6d5669715'
+ '412a58db507fa14268c9f30627d62fd448f9dccb')
diff --git a/fix-build-in-usr.patch b/fix-build-in-usr.patch
new file mode 100644
index 000000000000..44a3dd3e8c7e
--- /dev/null
+++ b/fix-build-in-usr.patch
@@ -0,0 +1,10 @@
+--- a/Tools/qmake/syncqt-4.8
++++ b/Tools/qmake/syncqt-4.8
+@@ -353,7 +353,6 @@
+ ######################################################################
+ sub fixPaths {
+ my ($file, $dir) = @_;
+- $dir =~ s=^$quoted_basedir/=$out_basedir/= if(!($basedir eq $out_basedir));
+ $file =~ s=\\=/=g;
+ $dir =~ s=\\=/=g;
+