summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2016-05-31 22:49:07 +0200
committerFlorian Bruhin2016-05-31 22:49:34 +0200
commit29bda0b7e1be110d18b039efa3b7a142b69a0785 (patch)
tree4fbcfec2fe042354812db5f3165db1111f67e870
downloadaur-29bda0b7e1be110d18b039efa3b7a142b69a0785.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8719c2176e37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue May 31 20:49:31 UTC 2016
+pkgbase = qtwebkit-plugins-git
+ pkgdesc = Spell checking plugin using Hunspell and HTML5 Notifications plugin for QtWebKit.
+ pkgver = 15.4e2e040
+ pkgrel = 1
+ url = https://github.com/QupZilla/qtwebkit-plugins
+ arch = i686
+ arch = x86_64
+ license = GPL3+
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = hunspell
+ source = git+https://github.com/QupZilla/qtwebkit-plugins.git
+ sha256sums = SKIP
+
+pkgname = qtwebkit-plugins-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7a74848f32e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=qtwebkit-plugins-git
+pkgver=15.4e2e040
+pkgrel=1
+pkgdesc='Spell checking plugin using Hunspell and HTML5 Notifications plugin for QtWebKit.'
+url='https://github.com/QupZilla/qtwebkit-plugins'
+arch=('i686' 'x86_64')
+license=('GPL3+')
+depends=('qt5-base' 'qt5-webkit' 'hunspell')
+makedepends=('git')
+source=('git+https://github.com/QupZilla/qtwebkit-plugins.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/qtwebkit-plugins"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "$srcdir/qtwebkit-plugins"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/qtwebkit-plugins"
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: