summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commitdf333dc49a523cba3f51c9fd7d9a87baa1bd1aaa (patch)
tree3b0b0919407fbaa8efd9310c92b6b1329edc9bd7
downloadaur-df333dc49a523cba3f51c9fd7d9a87baa1bd1aaa.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..474f4e86dd1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = quake-par
+ pkgdesc = Quake PAK archiving utility.
+ pkgver = 0.03.01
+ pkgrel = 1
+ url = ftp://ibiblio.org/pub/linux/games/quake/
+ license = GPL
+ depends = glibc
+ source = ftp://ibiblio.org/pub/linux/games/quake/par-0.03.01.tar.gz
+ md5sums = 39a73b5b95b04067dfc9acb8ef6bc9ff
+
+pkgname = quake-par
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f3b8a9d4e63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake-par
+pkgver=0.03.01
+pkgrel=1
+pkgdesc="Quake PAK archiving utility."
+url="ftp://ibiblio.org/pub/linux/games/quake/"
+license="GPL"
+depends=('glibc')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("ftp://ibiblio.org/pub/linux/games/quake/par-$pkgver.tar.gz")
+md5sums=('39a73b5b95b04067dfc9acb8ef6bc9ff')
+
+build() {
+ cd $startdir/src/par-$pkgver
+
+ # Modify Destination Directory in Makefile
+ /bin/sed -i "s:/usr/local:$startdir/pkg/usr:" Makefile.Linux
+
+ # Create Dirs
+ install -d $startdir/pkg/usr/{bin,man/man1}
+
+ ./configure
+ make || return 1
+ make install
+}