summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2011-02-07 21:14:07 -0500
committerSlashbunny2011-02-07 21:14:07 -0500
commit7cf2f96574960e4fbdd5bc587d757c9fc1b40e00 (patch)
treecf94abb2191caf37fd27b6638a39782adaf85b4e
downloadaur-7cf2f96574960e4fbdd5bc587d757c9fc1b40e00.tar.gz
New PKGBUILD for the Quake Retexturing Project stuffs
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b50f8cb496f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = quake-qrp-textures
+ pkgdesc = High Quality Textures for Quake from the Quake Revitalization Project (QRP)
+ pkgver = 1.00
+ pkgrel = 1
+ url = http://facelift.quakedev.com/
+ arch = any
+ license = custom
+ makedepends = p7zip
+ depends = quake
+ source = QRP_map_textures_v.1.00.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_map_textures_v.1.00.pk3.7z
+ source = QRP_normalmap_textures_add-on_v.1.00.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_normalmap_textures_add-on_v.1.00.pk3.7z
+ md5sums = 9958c0130d129aacdb36cbd4a68b1fbb
+ md5sums = ff88d1ef2b3e78560c2bd20843a25424
+
+pkgname = quake-qrp-textures
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2406b861f861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake-qrp-textures
+pkgver=1.00
+pkgrel=1
+pkgdesc="High Quality Textures for Quake from the Quake Revitalization Project (QRP)"
+url="http://facelift.quakedev.com/"
+license=('custom')
+arch=('any')
+depends=('quake')
+makedepends=('p7zip')
+conflicts=()
+provides=()
+install=
+source=("QRP_map_textures_v.${pkgver}.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_map_textures_v.${pkgver}.pk3.7z" \
+"QRP_normalmap_textures_add-on_v.${pkgver}.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_normalmap_textures_add-on_v.${pkgver}.pk3.7z")
+md5sums=('9958c0130d129aacdb36cbd4a68b1fbb'
+ 'ff88d1ef2b3e78560c2bd20843a25424')
+
+build() {
+ # Create Destination Directories
+ install -d $pkgdir/opt/quake/id1/
+
+ # Install Textures
+ 7z x -o$pkgdir/opt/quake/id1/ $srcdir/QRP_map_textures_v.${pkgver}.pk3.7z \
+ QRP_map_textures_v.${pkgver}.pk3
+
+ # Install Noramlmap Textures
+ 7z x -o$pkgdir/opt/quake/id1/ $srcdir/QRP_normalmap_textures_add-on_v.${pkgver}.pk3.7z \
+ QRP_normalmap_textures_add-on_v.${pkgver}.pk3
+}