summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2013-09-02 16:06:21 -0400
committerSlashbunny2013-09-02 16:06:21 -0400
commit83436579835e2d8adafc7ba9585bffd5f02bc004 (patch)
tree2f84b8f703934dc78b4a38dfc732db86bf033a53
parent7cf2f96574960e4fbdd5bc587d757c9fc1b40e00 (diff)
downloadaur-83436579835e2d8adafc7ba9585bffd5f02bc004.tar.gz
Modernized PKGBUILD, added working mirrors, removed 7z code since makepkg now extracts 7z files
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b50f8cb496f7..e4851769d3f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = quake-qrp-textures
pkgdesc = High Quality Textures for Quake from the Quake Revitalization Project (QRP)
pkgver = 1.00
- pkgrel = 1
- url = http://facelift.quakedev.com/
+ pkgrel = 2
+ url = http://qrp.quakeone.com/
arch = any
license = custom
- makedepends = p7zip
depends = quake
- source = QRP_map_textures_v.1.00.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_map_textures_v.1.00.pk3.7z
- source = QRP_normalmap_textures_add-on_v.1.00.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_normalmap_textures_add-on_v.1.00.pk3.7z
- md5sums = 9958c0130d129aacdb36cbd4a68b1fbb
- md5sums = ff88d1ef2b3e78560c2bd20843a25424
+ source = http://bfeared.com/library/quake/qrp/QRP_map_textures_v.1.00.pk3.7z
+ source = http://bfeared.com/library/quake/qrp/QRP_normalmap_textures_add-on_v.1.00.pk3.7z
+ sha256sums = ec05b443c77af87d5285f608684c1501158e4a74f03b090115120df7680b990d
+ sha256sums = 474f5845622c71eaf30c9199966ebc53768e5355bf71cdb2b765dae74af4c37e
pkgname = quake-qrp-textures
diff --git a/PKGBUILD b/PKGBUILD
index 2406b861f861..69ec425319f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=quake-qrp-textures
pkgver=1.00
-pkgrel=1
+pkgrel=2
pkgdesc="High Quality Textures for Quake from the Quake Revitalization Project (QRP)"
-url="http://facelift.quakedev.com/"
+url="http://qrp.quakeone.com/"
license=('custom')
arch=('any')
depends=('quake')
-makedepends=('p7zip')
-conflicts=()
-provides=()
-install=
-source=("QRP_map_textures_v.${pkgver}.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_map_textures_v.${pkgver}.pk3.7z" \
-"QRP_normalmap_textures_add-on_v.${pkgver}.pk3.7z::http://facelift.quakedev.com/downloads/dl_dod.se.php?f=QRP_normalmap_textures_add-on_v.${pkgver}.pk3.7z")
-md5sums=('9958c0130d129aacdb36cbd4a68b1fbb'
- 'ff88d1ef2b3e78560c2bd20843a25424')
-
-build() {
- # Create Destination Directories
- install -d $pkgdir/opt/quake/id1/
+source=("http://bfeared.com/library/quake/qrp/QRP_map_textures_v.1.00.pk3.7z" \
+"http://bfeared.com/library/quake/qrp/QRP_normalmap_textures_add-on_v.1.00.pk3.7z")
+sha256sums=('ec05b443c77af87d5285f608684c1501158e4a74f03b090115120df7680b990d'
+ '474f5845622c71eaf30c9199966ebc53768e5355bf71cdb2b765dae74af4c37e')
+PKGEXT='.pkg.tar'
+package() {
# Install Textures
- 7z x -o$pkgdir/opt/quake/id1/ $srcdir/QRP_map_textures_v.${pkgver}.pk3.7z \
- QRP_map_textures_v.${pkgver}.pk3
+ install -D -m644 ${srcdir}/QRP_map_textures_v.1.00.pk3 \
+ ${pkgdir}/opt/quake/id1/QRP_map_textures_v.1.00.pk3
# Install Noramlmap Textures
- 7z x -o$pkgdir/opt/quake/id1/ $srcdir/QRP_normalmap_textures_add-on_v.${pkgver}.pk3.7z \
- QRP_normalmap_textures_add-on_v.${pkgver}.pk3
+ install -D -m644 ${srcdir}/QRP_normalmap_textures_add-on_v.1.00.pk3 \
+ ${pkgdir}/opt/quake/id1/QRP_normalmap_textures_add-on_v.1.00.pk3
+
+ # Install License/Readme for base textures
+ install -D -m644 ${srcdir}/readme_mtex_v.1.00.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/readme_mtex_v.1.00.txt
+
+ # Install License/Readme for normalmaps
+ install -D -m644 ${srcdir}/readme_mtex_add-on_v.1.00.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/readme_mtex_add-on_v.1.00.txt
}