summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2011-07-05 20:55:30 -0400
committerSlashbunny2011-07-05 20:55:30 -0400
commitb15f4fb893a8cea784eda726b6e5a5e04308e3c1 (patch)
tree1a5af8a7e9d88a83e8b51963d5b69ca73b84396d
parente09a82bdd19d84a961eea2d495309015b96f4b97 (diff)
downloadaur-b15f4fb893a8cea784eda726b6e5a5e04308e3c1.tar.gz
Move rendering libs to quake base directory, make GLX default video mode in launcher
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--quake2.sh2
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83f4d4b7eeee..8cbef744704d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = quake2
pkgdesc = Quake 2 engine. You need the retail .pak files to play.
pkgver = r0.16.2
- pkgrel = 3
+ pkgrel = 4
url = http://www.icculus.org/quake2/
install = quake2.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d93a3d9434ef..2a969f109da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=quake2
pkgver=r0.16.2
-pkgrel=3
+pkgrel=4
pkgdesc="Quake 2 engine. You need the retail .pak files to play."
url="http://www.icculus.org/quake2/"
arch=('i686' 'x86_64')
@@ -132,7 +132,7 @@ build() {
install -m 755 rogue/game$_dirarch.so $pkgdir/opt/quake2/rogue/
# Install Additional Libraries
- cp ref_*.so $pkgdir/opt/quake2/baseq2/
+ cp ref_*.so $pkgdir/opt/quake2/
cd $srcdir
diff --git a/quake2.sh b/quake2.sh
index 4cfa862ae103..f5474ec2f7a0 100644
--- a/quake2.sh
+++ b/quake2.sh
@@ -1,6 +1,6 @@
#!/bin/bash
cd "/opt/quake2"
-./sdlquake2 +set basedir /opt/quake2 $*
+./sdlquake2 +set vid_ref glx +set basedir /opt/quake2 $*
exit $?