summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2010-07-07 22:24:54 -0400
committerSlashbunny2010-07-07 22:24:54 -0400
commite4f40e6479cb01776cec5715948d70d86314d3cb (patch)
tree48abc575ab43b4d70814d23b189903ab85d75609
parentcb1407a5d0afa2b6e20a574064508f221ad7f656 (diff)
downloadaur-e4f40e6479cb01776cec5715948d70d86314d3cb.tar.gz
Updated to latest version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77f98626be08..2499efaf76c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = quake2
pkgdesc = Quake 2 engine. You need the retail .pak files to play.
- pkgver = r0.16.1
- pkgrel = 8
+ pkgver = r0.16.2
+ pkgrel = 1
url = http://www.icculus.org/quake2/
install = quake2.install
arch = i686
@@ -13,7 +13,7 @@ pkgbase = quake2
depends = sdl
depends = libxxf86vm
depends = libxxf86dga
- source = http://www.icculus.org/quake2/files/quake2-r0.16.1.tar.gz
+ source = http://www.icculus.org/quake2/files/quake2-r0.16.2.tar.gz
source = http://www.icculus.org/quake2/files/maxpak.pak
source = http://cesium.di.uminho.pt/pub/games/quake2/source/xatrixsrc320.shar.Z
source = http://cesium.di.uminho.pt/pub/games/quake2/source/roguesrc320.shar.Z
@@ -25,7 +25,7 @@ pkgbase = quake2
source = ctf.sh
source = snd_alsa.c
source = gnusource.patch
- md5sums = 6b0e3fff324a5db58a8f8309dcabb47a
+ md5sums = 872fee27fb13a2a4c8876d5973c3c691
md5sums = 04d3f1fb7fb4dada7175a41f4595c7eb
md5sums = 41fc4ecc4f25c068e7d1f488bd4a1e1a
md5sums = 7d5e052839c9e629bad0a6570aa70554
diff --git a/PKGBUILD b/PKGBUILD
index 6cffefabca9a..cef9d8800c41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,22 @@
# Contributor: Premysl Janouch <warriant@gmail.com>
pkgname=quake2
-pkgver=r0.16.1
-pkgrel=8
+pkgver=r0.16.2
+pkgrel=1
pkgdesc="Quake 2 engine. You need the retail .pak files to play."
url="http://www.icculus.org/quake2/"
+arch=('i686' 'x86_64')
license=('GPL')
depends=('libjpeg' 'sdl' 'libxxf86vm' 'libxxf86dga')
makedepends=('patch' 'unzip')
-conflicts=()
-replaces=()
-backup=()
install="quake2.install"
-arch=('i686' 'x86_64')
source=("http://www.icculus.org/quake2/files/quake2-$pkgver.tar.gz" \
'http://www.icculus.org/quake2/files/maxpak.pak' \
'http://cesium.di.uminho.pt/pub/games/quake2/source/xatrixsrc320.shar.Z' \
'http://cesium.di.uminho.pt/pub/games/quake2/source/roguesrc320.shar.Z' \
'ftp://ftp.idsoftware.com/idstuff/quake2/q2-3.20-x86-full-ctf.exe' \
'quake2.sh' 'q2ded.sh' 'xatrix.sh' 'rogue.sh' 'ctf.sh' 'snd_alsa.c' 'gnusource.patch')
-md5sums=('6b0e3fff324a5db58a8f8309dcabb47a'
+md5sums=('872fee27fb13a2a4c8876d5973c3c691'
'04d3f1fb7fb4dada7175a41f4595c7eb'
'41fc4ecc4f25c068e7d1f488bd4a1e1a'
'7d5e052839c9e629bad0a6570aa70554'
@@ -68,7 +65,7 @@ build() {
patch -p1 < $srcdir/gnusource.patch
# Compile Quake 2
- make -s BUILD_XATRIX=YES BUILD_ROGUE=YES BUILD_DEDICATED=YES BUILD_CTF=YES BUILD_QMAX=YES build_release || return 1
+ make -s BUILD_XATRIX=YES BUILD_ROGUE=YES BUILD_DEDICATED=YES BUILD_CTF=YES BUILD_QMAX=YES build_release
[ "$CARCH" = "i686" ] && _dirarch=i386
[ "$CARCH" = "x86_64" ] && _dirarch=x86_64