summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2011-11-05 17:09:26 -0400
committerSlashbunny2011-11-05 17:09:26 -0400
commit38df80b3b96e31de335ebf321c107d20f7e7c3b9 (patch)
tree3796d83c114b65db7a8ef876022929ad8ff5135d
parentf41bb3e59344ccc527a34481cd7d0e59f5b29dca (diff)
downloadaur-38df80b3b96e31de335ebf321c107d20f7e7c3b9.tar.gz
update quake3 mirrors; patch botlib on ioquake3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD86
-rw-r--r--quake3-smp.launcher3
-rw-r--r--quake3.install32
-rw-r--r--quake3.launcher3
-rw-r--r--quake3ded.launcher3
6 files changed, 69 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41b15ec5fa83..dc1364c9774d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,19 +8,20 @@ pkgbase = quake3
arch = x86_64
license = GPL
makedepends = unzip
+ conflicts = ioquake3
conflicts = ioquake3-svn
source = quake3.install
source = quake3.desktop
source = quake3.launcher
source = quake3-smp.launcher
source = quake3ded.launcher
- source = ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run
- source = ftp://ftp.idsoftware.com/idstuff/quake3/quake3-1.32c.zip
- md5sums = df46c620394b94dad07bcee2a25aa2ce
+ source = http://media1.gamefront.com/moddb/2008/06/03/linuxq3apoint-1.32b-3.x86.run
+ source = http://ftp.mancubus.net/pub/idgames/idstuff/quake3/quake3-1.32c.zip
+ md5sums = 330f17b7664f8d0ff98ef173bd37fa33
md5sums = 4b3656ccf6b6f6967f53e0977d7e5c0a
- md5sums = dbb6faaf7ffdbd4dc3c1fd2639a2923b
- md5sums = 413af8ac8dcdcfffb35a10577e7b48ba
- md5sums = 8f23bbc33ba5b0e42131f18b6771c4a3
+ md5sums = b99913defd8c2c8b2f1b9006f5ddeb9f
+ md5sums = a394dea42844aabfe188f56415950908
+ md5sums = 23710b0dc75e238f6858ad04c872fe91
md5sums = c71fdddccb20e8fc393d846e9c61d685
md5sums = 5e55095e654732063621a2ffa95a2da3
diff --git a/PKGBUILD b/PKGBUILD
index 95254dd1793a..f2e022551458 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,63 +10,63 @@ arch=('i686' 'x86_64')
[ "${CARCH}" = "i686" ] && depends=('libgl' 'libxext')
[ "${CARCH}" = "x86_64" ] && depends=('lib32-libgl' 'lib32-libxext')
makedepends=('unzip')
-conflicts=('ioquake3-svn')
+conflicts=('ioquake3' 'ioquake3-svn')
install=quake3.install
source=('quake3.install' 'quake3.desktop' 'quake3.launcher' 'quake3-smp.launcher' 'quake3ded.launcher' \
-'ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run' \
-'ftp://ftp.idsoftware.com/idstuff/quake3/quake3-1.32c.zip')
-md5sums=('df46c620394b94dad07bcee2a25aa2ce'
+'http://media1.gamefront.com/moddb/2008/06/03/linuxq3apoint-1.32b-3.x86.run' \
+'http://ftp.mancubus.net/pub/idgames/idstuff/quake3/quake3-1.32c.zip')
+md5sums=('330f17b7664f8d0ff98ef173bd37fa33'
'4b3656ccf6b6f6967f53e0977d7e5c0a'
- 'dbb6faaf7ffdbd4dc3c1fd2639a2923b'
- '413af8ac8dcdcfffb35a10577e7b48ba'
- '8f23bbc33ba5b0e42131f18b6771c4a3'
+ 'b99913defd8c2c8b2f1b9006f5ddeb9f'
+ 'a394dea42844aabfe188f56415950908'
+ '23710b0dc75e238f6858ad04c872fe91'
'c71fdddccb20e8fc393d846e9c61d685'
'5e55095e654732063621a2ffa95a2da3')
build() {
- cd $startdir/src
+ cd $srcdir
- # Create Destination Package Directories
- install -d $startdir/pkg/opt/quake3/{baseq3,missionpack}
-
- # Extract Files from Installer
- chmod +x $startdir/src/linuxq3apoint-1.32b-3.x86.run
- $startdir/src/linuxq3apoint-1.32b-3.x86.run --tar xf
+ # Create Destination Package Directories
+ install -d $pkgdir/opt/quake3/{baseq3,missionpack}
- # Install BaseQ3 pk3 files
- install -m 644 -t $startdir/pkg/opt/quake3/baseq3/ \
- $startdir/src/baseq3/*.pk3
+ # Extract Files from Installer
+ chmod +x $srcdir/linuxq3apoint-1.32b-3.x86.run
+ $srcdir/linuxq3apoint-1.32b-3.x86.run --tar xf
- # Install Missionpack pk3 files
- install -m 644 -t $startdir/pkg/opt/quake3/missionpack/ \
- $startdir/src/missionpack/*.pk3
+ # Install BaseQ3 pk3 files
+ install -m 644 -t $pkgdir/opt/quake3/baseq3/ \
+ $srcdir/baseq3/*.pk3
- # Install PB Files
- chown -R root:root $startdir/src/pb
- mv $startdir/src/pb $startdir/pkg/opt/quake3/
+ # Install Missionpack pk3 files
+ install -m 644 -t $pkgdir/opt/quake3/missionpack/ \
+ $srcdir/missionpack/*.pk3
- # Install 1.32c Binaries
- install -m 755 -t $startdir/pkg/opt/quake3/ \
- $startdir/src/Quake\ III\ Arena\ 1.32c/linux/{q3ded,quake3-smp.x86,quake3.x86}
+ # Install PB Files
+ chown -R root:root $srcdir/pb
+ mv $srcdir/pb $pkgdir/opt/quake3/
- # Install Launcher (Client)
- install -D -m 755 $startdir/src/quake3.launcher \
- $startdir/pkg/usr/bin/quake3
+ # Install 1.32c Binaries
+ install -m 755 -t $pkgdir/opt/quake3/ \
+ $srcdir/Quake\ III\ Arena\ 1.32c/linux/{q3ded,quake3-smp.x86,quake3.x86}
- # Install Launcher (SMP Client)
- install -D -m 755 $startdir/src/quake3-smp.launcher \
- $startdir/pkg/usr/bin/quake3-smp
+ # Install Launcher (Client)
+ install -D -m 755 $srcdir/quake3.launcher \
+ $pkgdir/usr/bin/quake3
- # Install Launcher (Server)
- install -D -m 755 $startdir/src/quake3ded.launcher \
- $startdir/pkg/usr/bin/quake3ded
-
- # Install Desktop File
- install -D -m 644 $startdir/src/quake3.desktop \
- $startdir/pkg/usr/share/applications/quake3.desktop
+ # Install Launcher (SMP Client)
+ install -D -m 755 $srcdir/quake3-smp.launcher \
+ $pkgdir/usr/bin/quake3-smp
- # Install Icon File
- install -D -m 644 $startdir/src/quake3.xpm \
- $startdir/pkg/usr/share/pixmaps/quake3.xpm
-}
+ # Install Launcher (Server)
+ install -D -m 755 $srcdir/quake3ded.launcher \
+ $pkgdir/usr/bin/quake3ded
+
+ # Install Desktop File
+ install -D -m 644 $srcdir/quake3.desktop \
+ $pkgdir/usr/share/applications/quake3.desktop
+
+ # Install Icon File
+ install -D -m 644 $srcdir/quake3.xpm \
+ $pkgdir/usr/share/pixmaps/quake3.xpm
+}
diff --git a/quake3-smp.launcher b/quake3-smp.launcher
index e77ac3d3e4c3..23617aee031c 100644
--- a/quake3-smp.launcher
+++ b/quake3-smp.launcher
@@ -1,6 +1,5 @@
#!/bin/bash
cd "/opt/quake3"
-./quake3-smp.x86 $*
-exit $?
+exec ./quake3-smp.x86 $*
diff --git a/quake3.install b/quake3.install
index 70ada647c34a..4fbc954ab764 100644
--- a/quake3.install
+++ b/quake3.install
@@ -1,27 +1,27 @@
post_install() {
- echo ">>>"
- echo ">>>>To play Q3 with the Retail Version:"
- echo ">>> Move the pak0.pk3 file from the original game CD to"
- echo ">>> /opt/quake3/baseq3/"
- echo ">>>"
- echo ">>>>To play Q3 with the Demo Version:"
- echo ">>> You need the demoq3/pak0.pk3 from the demo installer. The"
- echo ">>> qvm files inside that pk3 file will not work, so you have"
- echo ">>> to copy or link the .so files in the baseq3/ directory to"
- echo ">>> /opt/quake3/demoq3/ with the pak0.pk3 file."
- echo ">>>"
- echo ">>>>When you have the .pk3 file(s) installed, run the game:"
- echo ">>> quake3"
- echo ">>>"
+ echo ">>>"
+ echo ">>>>To play Q3 with the Retail Version:"
+ echo ">>> Move the pak0.pk3 file from the original game CD to"
+ echo ">>> /opt/quake3/baseq3/"
+ echo ">>>"
+ echo ">>>>To play Q3 with the Demo Version:"
+ echo ">>> You need the demoq3/pak0.pk3 from the demo installer. The"
+ echo ">>> qvm files inside that pk3 file will not work, so you have"
+ echo ">>> to copy or link the .so files in the baseq3/ directory to"
+ echo ">>> /opt/quake3/demoq3/ with the pak0.pk3 file."
+ echo ">>>"
+ echo ">>>>When you have the .pk3 file(s) installed, run the game:"
+ echo ">>> quake3"
+ echo ">>>"
}
post_upgrade() {
- post_install $1
+ post_install $1
}
pre_remove() {
- /bin/true
+ /bin/true
}
op=$1
diff --git a/quake3.launcher b/quake3.launcher
index 75dcead5b027..d724ec1f7a8b 100644
--- a/quake3.launcher
+++ b/quake3.launcher
@@ -1,6 +1,5 @@
#!/bin/bash
cd "/opt/quake3"
-./quake3.x86 $*
-exit $?
+exec ./quake3.x86 $*
diff --git a/quake3ded.launcher b/quake3ded.launcher
index e531a71be135..386f8c6f3342 100644
--- a/quake3ded.launcher
+++ b/quake3ded.launcher
@@ -1,6 +1,5 @@
#!/bin/bash
cd "/opt/quake3"
-./q3ded $*
-exit $?
+exec ./q3ded $*