summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit36d99b08f4b169e9801a2ca92a4bb250848b896f (patch)
tree19465bb51a43b5532075b808349394effbaca241
downloadaur-36d99b08f4b169e9801a2ca92a4bb250848b896f.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6218d70d782
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = quake3-osp
+ pkgdesc = Orange Smoothie Productions (OSP) is a modification for Quake 3 that adds many client and server features while still being compatable with the stock game.
+ pkgver = 1.03a
+ pkgrel = 2
+ url = http://en.wikipedia.org/wiki/Orange_Smoothie_Productions
+ arch = i686
+ arch = x86_64
+ depends = quake3
+ source = http://www.sunflow.com/orangesmoothie/downloads/osp-Quake3-1.03a_full.zip
+ md5sums = 8b2b4925cce1895067bc617b86c62ea5
+
+pkgname = quake3-osp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcf2384c9927
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake3-osp
+pkgver=1.03a
+pkgrel=2
+pkgdesc="Orange Smoothie Productions (OSP) is a modification for Quake 3 that adds many client and server features while still being compatable with the stock game."
+url="http://en.wikipedia.org/wiki/Orange_Smoothie_Productions"
+license=('')
+arch=('i686' 'x86_64')
+depends=('quake3')
+source=('http://www.sunflow.com/orangesmoothie/downloads/osp-Quake3-1.03a_full.zip')
+md5sums=('8b2b4925cce1895067bc617b86c62ea5')
+
+build() {
+ cd $startdir/src/
+
+ # Base OSP Files
+ install -d $startdir/pkg/opt/quake3/
+ unzip osp-Quake3-1.03a_full.zip -d $startdir/pkg/opt/quake3/
+}