summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2021-04-15 22:18:22 -0400
committerSlashbunny2021-04-15 22:18:22 -0400
commitf035336ce96732a495011e0bb00d04e128ec445b (patch)
tree7f30b85b20b837b0b757b1cd65163faab03ba836
parent6923e65917c31497f74642275825229f374c4b3e (diff)
downloadaur-f035336ce96732a495011e0bb00d04e128ec445b.tar.gz
misc tweaks
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7874a00a3ed..db0a35fc72f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,13 +2,14 @@ pkgbase = quake3-osp
pkgdesc = Orange Smoothie Productions (OSP) is a modification for Quake 3 that adds many client and server features while still being compatable with the stock game.
pkgver = 1.03a
pkgrel = 3
- url = http://www.orangesmoothie.org/
+ url = https://www.orangesmoothie.org/
arch = any
license = custom
+ makedepends = unzip
depends = quake3
noextract = osp-Quake3-1.03a_full.zip
- source = http://osp.dget.cc/orangesmoothie/downloads/osp-Quake3-1.03a_full.zip
- md5sums = 8b2b4925cce1895067bc617b86c62ea5
+ source = https://osp.dget.cc/orangesmoothie/downloads/osp-Quake3-1.03a_full.zip
+ sha512sums = 9a9bc76ca2e582432e0f8ff6a3fe0bd2e0b0767a1f52bdea8debc7bc9053dc78951335da085b88e0f3690f1f7fda25a628cff9bace7f683f543c5eff90307e19
pkgname = quake3-osp
diff --git a/.gitignore b/.gitignore
index e4f398dc5b3a..5203dab25dc5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
src/
pkg/
-*.pkg.tar.xz
+*.pkg.tar.zst
*.pkg.tar
*.src.tar.gz
+osp-Quake3-*_full.zip
diff --git a/PKGBUILD b/PKGBUILD
index 28553c4d2512..6c3d0b15284f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=quake3-osp
pkgver=1.03a
pkgrel=3
pkgdesc="Orange Smoothie Productions (OSP) is a modification for Quake 3 that adds many client and server features while still being compatable with the stock game."
-url="http://www.orangesmoothie.org/"
+url="https://www.orangesmoothie.org/"
license=('custom')
arch=('any')
depends=('quake3')
-source=("http://osp.dget.cc/orangesmoothie/downloads/osp-Quake3-${pkgver}_full.zip")
-md5sums=('8b2b4925cce1895067bc617b86c62ea5')
+makedepends=('unzip')
+source=("https://osp.dget.cc/orangesmoothie/downloads/osp-Quake3-${pkgver}_full.zip")
+sha512sums=('9a9bc76ca2e582432e0f8ff6a3fe0bd2e0b0767a1f52bdea8debc7bc9053dc78951335da085b88e0f3690f1f7fda25a628cff9bace7f683f543c5eff90307e19')
noextract=("osp-Quake3-${pkgver}_full.zip")
package() {
- cd ${srcdir};
+ cd "${srcdir}";
- # Base OSP Files
- install -d ${pkgdir}/opt/quake3/
- unzip osp-Quake3-1.03a_full.zip -d ${pkgdir}/opt/quake3/
+ install -d "${pkgdir}/opt/quake3/";
+
+ # Extract base OSP files
+ unzip osp-Quake3-1.03a_full.zip -d "${pkgdir}/opt/quake3/"
+
+ # Correct directory and file permissions
+ find "${pkgdir}/opt/quake3/" \! -perm 644 -type f -exec chmod -v 644 {} \;
+ find "${pkgdir}/opt/quake3/" \! -perm 755 -type d -exec chmod -v 755 {} \;
}