summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commiteba66a5a82b63dddfac89d21331256921187349a (patch)
treeb1c4449313c8795e2623ec38bbe3256dd2e28110
downloadaur-eba66a5a82b63dddfac89d21331256921187349a.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46cda5875b04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = quake3-reactionq3
+ pkgdesc = Reaction Quake 3 is modification for Quake 3 modeled after games like ActionQ2 and ActionHL, that recreate an action movie atmosphere.
+ pkgver = 3.2
+ pkgrel = 1
+ url = http://www.rq3.com/
+ depends = quake3
+ source = http://www.rq3.com/ReactionQuake3-v3.2-Full.zip
+ md5sums = 9d376db7be9c2990953b93fae075458b
+
+pkgname = quake3-reactionq3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a6ad48a95ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake3-reactionq3
+pkgver=3.2
+pkgrel=1
+pkgdesc="Reaction Quake 3 is modification for Quake 3 modeled after games like ActionQ2 and ActionHL, that recreate an action movie atmosphere."
+url="http://www.rq3.com/"
+license=""
+depends=('quake3')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=('http://www.rq3.com/ReactionQuake3-v3.2-Full.zip')
+md5sums=('9d376db7be9c2990953b93fae075458b')
+
+build() {
+ cd $startdir/src/
+
+ # Base RQ3 Files
+ install -d $startdir/pkg/opt/quake3/
+ unzip ReactionQuake3-v3.2-Full.zip -d $startdir/pkg/opt/quake3/
+}