summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2015-06-08 18:46:58 -0400
commit70139c150de41b21c222d30ff28934b8c7de5c60 (patch)
treef1264742b54cb56a62bedf9ceac2770eaf27c471
downloadaur-70139c150de41b21c222d30ff28934b8c7de5c60.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12a48c72dc81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = quake3-rocketarena
+ pkgdesc = Rocket Arena is a modification for Quake 3 where players compete in multiple arenas tournament style.
+ pkgver = 1.80
+ pkgrel = 1
+ url = http://rocketarena.planetquake.gamespy.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = quake3
+ source = http://games.mirrors.tds.net/pub/planetquake3/modifications/rocketarena3/ra3180.zip
+ md5sums = 68e9ac4f5571d85c963e985193c16230
+
+pkgname = quake3-rocketarena
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0e0d9855e99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake3-rocketarena
+pkgver=1.80
+pkgrel=1
+pkgdesc="Rocket Arena is a modification for Quake 3 where players compete in multiple arenas tournament style."
+url="http://rocketarena.planetquake.gamespy.com/"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('quake3')
+source=('http://games.mirrors.tds.net/pub/planetquake3/modifications/rocketarena3/ra3180.zip')
+md5sums=('68e9ac4f5571d85c963e985193c16230')
+
+build() {
+ # Create Destination Directories
+ install -d $startdir/pkg/opt/quake3/
+
+ # Delete Useless Files
+
+ # Install RA3 Files
+ cp -r $startdir/src/arena \
+ $startdir/pkg/opt/quake3/
+}