summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commitc482bb0b71b3dd8290050af90bff0e2bff301e4f (patch)
tree3b2cc62a68f431c45c02ad9912aa607d8f70e34e
downloadaur-c482bb0b71b3dd8290050af90bff0e2bff301e4f.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98cb964a8233
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = quake3-threewave
+ pkgdesc = Threewave is a modification for Quake 3 that features Capture the Flag (CTF) gameplay.
+ pkgver = 1.7
+ pkgrel = 1
+ url = http://www.threewavesoftware.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = quake3
+ source = http://games.mirrors.tds.net/pub/planetquake3/modifications/threewavectf/threewave_16_full.zip
+ source = http://games.mirrors.tds.net/pub/planetquake3/modifications/threewavectf/threewave_17_update.zip
+ md5sums = 9a5751ab2901e65d95b8134fc78c9bab
+ md5sums = c8bdda7722716f18f45a8b2e50f4d020
+
+pkgname = quake3-threewave
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..568998cbfad2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake3-threewave
+pkgver=1.7
+pkgrel=1
+pkgdesc="Threewave is a modification for Quake 3 that features Capture the Flag (CTF) gameplay."
+url="http://www.threewavesoftware.com/"
+license="custom"
+arch=('i686' 'x86_64')
+depends=('quake3')
+source=('http://games.mirrors.tds.net/pub/planetquake3/modifications/threewavectf/threewave_16_full.zip' \
+'http://games.mirrors.tds.net/pub/planetquake3/modifications/threewavectf/threewave_17_update.zip')
+md5sums=('9a5751ab2901e65d95b8134fc78c9bab'
+ 'c8bdda7722716f18f45a8b2e50f4d020')
+
+build() {
+ # Create Destination Directories
+ install -d $startdir/pkg/opt/quake3/
+
+ # Install Threewave CTF Files
+ cp -r $startdir/src/{baseq3,threewave} \
+ $startdir/pkg/opt/quake3/
+}