summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit7a8333b560c415f75573026a95593ae40ed68b6d (patch)
treee6992715f6fb510c7708070b52a6cf6bf7f45307
downloadaur-7a8333b560c415f75573026a95593ae40ed68b6d.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD77
-rw-r--r--quake4-dedicated.launcher6
-rw-r--r--quake4-smp.launcher6
-rw-r--r--quake4.desktop12
-rw-r--r--quake4.install48
-rw-r--r--quake4.launcher6
8 files changed, 186 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19bf546f1c3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = quake4
+ pkgdesc = Quake 4 Engine. You need the retail .pk4 files to play.
+ pkgver = 1.4.2
+ pkgrel = 2
+ url = http://www.quake4game.com/
+ install = quake4.install
+ arch = i686
+ license = custom:"Quake 4"
+ license = custom:"PunkBuster"
+ depends = gcc-libs
+ depends = libgl
+ depends = sdl
+ depends = zlib
+ source = quake4.desktop
+ source = quake4.launcher
+ source = quake4-dedicated.launcher
+ source = quake4-smp.launcher
+ source = http://www.1337-server.net/quake4/quake4-linux-1.4.2.x86.run.gz
+ md5sums = c05b4551aa7cc8728eee9e3f94fcea1e
+ md5sums = ece76fd2e52d2eec7584ab1e8832410b
+ md5sums = b479a067fdf376384e39cbff41911327
+ md5sums = 19acb4c06f9c8e7bf03aa021c56e4242
+ md5sums = b186954ab5fbadd57f7ca9519b5b0503
+
+pkgname = quake4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab7f94e1b995
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+
+pkgname=quake4
+pkgver=1.4.2
+pkgrel=2
+pkgdesc="Quake 4 Engine. You need the retail .pk4 files to play."
+url="http://www.quake4game.com/"
+license=('custom:"Quake 4"' \
+ 'custom:"PunkBuster"')
+depends=('gcc-libs' 'libgl' 'sdl' 'zlib')
+arch=('i686')
+install=quake4.install
+source=('quake4.desktop' 'quake4.launcher' 'quake4-dedicated.launcher' 'quake4-smp.launcher' \
+"http://www.1337-server.net/quake4/quake4-linux-${pkgver}.x86.run.gz")
+md5sums=('c05b4551aa7cc8728eee9e3f94fcea1e'
+ 'ece76fd2e52d2eec7584ab1e8832410b'
+ 'b479a067fdf376384e39cbff41911327'
+ '19acb4c06f9c8e7bf03aa021c56e4242'
+ 'b186954ab5fbadd57f7ca9519b5b0503')
+
+build() {
+ cd $srcdir
+
+ # Create Destination Directories
+ install -d $pkgdir/opt/
+
+ # Make Installer Executable
+ chmod +x $srcdir/quake4-linux-${pkgver}.x86.run
+
+ # Extract Files from Installer
+ $srcdir/quake4-linux-${pkgver}.x86.run --noexec --target quake4
+
+ # Move pk4 files to correct location
+ mv $srcdir/quake4/us/q4base/*.pk4 \
+ $srcdir/quake4/q4base/
+
+ # Move Executables and Libraries
+ install -m 755 -t $srcdir/quake4/ \
+ $srcdir/quake4/bin/Linux/x86/{lib*,q4ded*,quake4*}
+
+ # Make Everything World-Readable
+ chmod -R a+r $srcdir/quake4/
+
+ # Remove Unneeded Files
+ rm -rf $srcdir/quake4/{germany/,setup.data/,setup.sh,us/,bin/}
+
+ # Move Quake4 to Destination Directory
+ mv $srcdir/quake4 $pkgdir/opt/
+
+ # Install Launcher (Client)
+ install -D -m 755 $srcdir/quake4.launcher \
+ $pkgdir/usr/bin/quake4
+
+ # Install Launcher (Client - SMP)
+ install -D -m 755 $srcdir/quake4-smp.launcher \
+ $pkgdir/usr/bin/quake4-smp
+
+ # Install Launcher (Server)
+ install -D -m 755 $srcdir/quake4-dedicated.launcher \
+ $pkgdir/usr/bin/quake4-dedicated
+
+ # Install License (Quake 4)
+ install -D -m 644 $pkgdir/opt/quake4/License.txt \
+ $pkgdir/usr/share/licenses/quake4/License.txt
+
+ # Install License (PunkBuster)
+ install -D -m 644 $pkgdir/opt/quake4/pb/PBEULA.txt \
+ $pkgdir/usr/share/licenses/quake4/PBEULA.txt
+
+ # Install Desktop File
+ install -D -m 644 $srcdir/quake4.desktop \
+ $pkgdir/usr/share/applications/quake4.desktop
+
+ # Install Icon File
+ install -D -m 644 $pkgdir/opt/quake4/q4icon.bmp \
+ $pkgdir/usr/share/pixmaps/quake4.bmp
+}
diff --git a/quake4-dedicated.launcher b/quake4-dedicated.launcher
new file mode 100644
index 000000000000..b499e3c6c2cc
--- /dev/null
+++ b/quake4-dedicated.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/quake4"
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
+./q4ded.x86 $*
+exit $?
diff --git a/quake4-smp.launcher b/quake4-smp.launcher
new file mode 100644
index 000000000000..9831e1ed0f06
--- /dev/null
+++ b/quake4-smp.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/quake4"
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
+./quake4smp.x86 $*
+exit $?
diff --git a/quake4.desktop b/quake4.desktop
new file mode 100644
index 000000000000..d1b3ba33bf8c
--- /dev/null
+++ b/quake4.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Quake 4
+GenericName=Quake 4
+Comment=Quake 4
+Exec=/usr/bin/quake4
+Icon=/usr/share/pixmaps/quake4.bmp
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Qt;KDE;GNOME;Application;Game;
+
diff --git a/quake4.install b/quake4.install
new file mode 100644
index 000000000000..34b556be8365
--- /dev/null
+++ b/quake4.install
@@ -0,0 +1,48 @@
+post_install() {
+cat << EOF
+IMPORTANT
+==> In order to use the software, you have to agree to ID Software's license
+==> located in /opt/quake4/License.txt and Punkbuster's license located in
+==> /opt/quake4/pb/PBEULA.txt.
+==> If you don't, please remove this package (pacman -R quake4)
+
+EOF
+
+cat <<-00installInstructions00
+The following files must be copied from the install CDs [1]
+to your q4base/ directory ( md5 sums provided as reference ):
+
+If you copy them before running the installer you will need to
+create the paths, by default /opt/quake4/q4base. Make sure not
+to replace any paks the installer might have provided.
+
+b201b914167f47061fa5f975af527122 pak001.pk4
+dabe2c88e004198947431250e3f4ca1d pak002.pk4
+8573f05af4c9568880cc464d06292079 pak003.pk4
+12ff4006a7f7181ac16835d05c59905f pak004.pk4
+3576213f4e00f06baf3cd5de089a538a pak005.pk4
+aec7bb418b9a86256f9e5daee894dee2 pak006.pk4
+0f53b4fb4df2c14fcd10012baf8b2f87 pak007.pk4
+b099d75869f0ffcbcb8e5166374af345 pak008.pk4
+cb2b44bf573559dc19b488d9e1e5bec3 pak009.pk4
+d024073349dc917b4feab49e6abc417b pak010.pk4
+98c854d94ce1da5272952b77821823df pak011.pk4
+e77a2fda6656495d38773e05bbffda33 pak012.pk4
+669d6d9a30b798d19434972475b98c53 zpak_english.pk4
+2cabddd692e214c78c20a464da43f1ef zpak_french.pk4
+4ee7eb637cde6bcfe3a9ffac5e4579dd zpak_italian.pk4
+36eee38e6c2dce12986f7192a5a996e5 zpak_spanish.pk4
+
+Start the game with the command: quake4
+Start the dedicated server with the command: quake4-dedicated
+
+For troubleshooting and help, see:
+http://zerowing.idsoftware.com/linux/
+00installInstructions00
+ /bin/true
+}
+
+
+op=$1
+shift
+$op $*
diff --git a/quake4.launcher b/quake4.launcher
new file mode 100644
index 000000000000..95171e4187e7
--- /dev/null
+++ b/quake4.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/quake4"
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
+./quake4.x86 $*
+exit $?