summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMelanie Scheirer2022-08-28 21:27:03 -0400
committerMelanie Scheirer2022-08-28 21:27:03 -0400
commit0c7fb601282a7ebd1d0229c26c8e7add72753257 (patch)
treec330c6ed9d0c9ab58cf142f5826c82c4dd997490
downloadaur-quakeinjector-bin.tar.gz
Initial commit, alpha 05
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
-rwxr-xr-xquakeinjector.desktop7
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c47724631e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = quakeinjector-bin
+ pkgdesc = Download, install and play quake singleplayer maps from the quaddicted.com archive, binary distribution
+ pkgver = alpha05
+ pkgrel = 1
+ url = https://github.com/hrehfeld/QuakeInjector
+ arch = any
+ license = GPL
+ depends = java-environment
+ depends = hicolor-icon-theme
+ provides = quakeinjector
+ conflicts = quakeinjector-git
+ replaces = quakeinjector
+ source = https://github.com/hrehfeld/QuakeInjector/releases/download/alpha05/QuakeInjector-alpha05.zip
+ source = quakeinjector.desktop
+ sha256sums = 9cbc1ed86aab077c91eff024d81cf0341abee6e0f40ea4a9eb7ff7c6f79711ee
+ sha256sums = 24dccb15d1fe176009f1f637172e434553fdef8726e7f42c66307725bccf94bc
+
+pkgname = quakeinjector-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..105d350bc584
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mel <mel@nie.rs>
+pkgname=quakeinjector-bin
+_xtname=QuakeInjector
+pkgver=alpha05
+pkgrel=1
+pkgdesc="Download, install and play quake singleplayer maps from the quaddicted.com archive, binary distribution"
+url="https://github.com/hrehfeld/QuakeInjector"
+arch=(any)
+license=(GPL)
+depends=(java-environment hicolor-icon-theme)
+makedepends=()
+provides=(quakeinjector)
+conflicts=(quakeinjector-git)
+replaces=(quakeinjector)
+source=("https://github.com/hrehfeld/QuakeInjector/releases/download/$pkgver/$_xtname-$pkgver.zip"
+ 'quakeinjector.desktop')
+sha256sums=('9cbc1ed86aab077c91eff024d81cf0341abee6e0f40ea4a9eb7ff7c6f79711ee'
+ '24dccb15d1fe176009f1f637172e434553fdef8726e7f42c66307725bccf94bc')
+
+package() {
+ install -Dm644 "$srcdir/${pkgname/-bin}.desktop" "$pkgdir/usr/share/applications/{$pkgname/-bin}.desktop"
+ install -Dm644 "$srcdir/$_xtname-$pkgver/lib/$_xtname-$pkgver.jar" "$pkgdir/usr/share/$pkgname/$pkgname.jar"
+}
diff --git a/quakeinjector.desktop b/quakeinjector.desktop
new file mode 100755
index 000000000000..338acd199e8a
--- /dev/null
+++ b/quakeinjector.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Comment=Load and play Quake maps and engines.
+Exec=java -jar /usr/share/quakeinjector-bin/quakeinjector-bin.jar
+GenericName=Quake Map Loader
+Icon=quakeinjector
+Name=Quake Injector
+Type=Application