summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Scheirer2016-07-08 16:49:21 -0400
committerMatthew Scheirer2016-07-08 16:49:21 -0400
commit9a12fdfc11343db0ed7c1278c155d2baf4e7e8fd (patch)
tree2b8284a12d3c25f60a637c2bd4967039372ab0bc
downloadaur-9a12fdfc11343db0ed7c1278c155d2baf4e7e8fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rwxr-xr-xquakeinjector.desktop7
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acf7a47614ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jul 8 20:49:10 UTC 2016
+pkgbase = quakeinjector-git
+ pkgdesc = Download, install and play quake singleplayer maps from the quaddicted.com archive
+ pkgver = alpha02.r53.d65cfb3
+ pkgrel = 1
+ url = http://www.haukerehfeld.de/projects/quakeinjector/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = apache-ant
+ depends = java-environment
+ depends = hicolor-icon-theme
+ provides = quakeinjector
+ conflicts = quakeinjector
+ replaces = quakeinjector
+ source = git+https://github.com/hrehfeld/QuakeInjector.git
+ source = quakeinjector.desktop
+ md5sums = SKIP
+ md5sums = c55fafa5ffa3c9c9cb1188d493e34671
+
+pkgname = quakeinjector-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..057783554865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zanny <lordzanny@gmail.com
+pkgname=quakeinjector-git
+_name=quakeinjector
+_gitname=QuakeInjector
+pkgver=alpha02.r53.d65cfb3
+pkgrel=1
+pkgdesc="Download, install and play quake singleplayer maps from the quaddicted.com archive"
+url="http://www.haukerehfeld.de/projects/quakeinjector/"
+arch=(any)
+license=(GPL)
+depends=(java-environment hicolor-icon-theme)
+makedepends=(git apache-ant)
+provides=(quakeinjector)
+conflicts=(quakeinjector)
+replaces=(quakeinjector)
+source=("git+https://github.com/hrehfeld/$_gitname.git"
+ 'quakeinjector.desktop')
+md5sums=(SKIP
+ 'c55fafa5ffa3c9c9cb1188d493e34671')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ ant quakeinjector.jar
+}
+
+package() {
+ for res in '16' '32' '48' '256'; do
+ install -Dm644 "$srcdir/$_gitname/res/Inject2_$res.png" "$pkgdir/usr/share/icons/hicolor/${res}x$res/apps/$_name.png"
+ done
+ install -Dm644 "$srcdir/$_name.desktop" "$pkgdir/usr/share/applications/$_name.desktop"
+ install -Dm644 "$srcdir/$_gitname/dist/$_name.jar" "$pkgdir/usr/share/$_name/$_name.jar"
+ install -Dm644 "$srcdir/$_gitname/dist/$_name-res.jar" "$pkgdir/usr/share/$_name/$_name-res.jar"
+}
diff --git a/quakeinjector.desktop b/quakeinjector.desktop
new file mode 100755
index 000000000000..809c0b59f02c
--- /dev/null
+++ b/quakeinjector.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Comment=Load and play Quake maps and engines.
+Exec=java -jar /usr/share/quakeinjector/quakeinjector.jar
+GenericName=Quake Map Loader
+Icon=quakeinjector
+Name=Quake Injector
+Type=Application