summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantasqueX2022-06-05 12:34:23 +0800
committerFantasqueX2022-06-05 12:34:23 +0800
commitf0df676a0a74805dd5b03efcd4a499b747ef8126 (patch)
treeeeb413c5c9851c2dd43a8aa7ffff7f3895f0668f
parentdcc96a3c873140219a1cee0656bdae86ba170c29 (diff)
downloadaur-f0df676a0a74805dd5b03efcd4a499b747ef8126.tar.gz
upgrade to 3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b18c403d11cc..01f19ef6e150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = qualcoder
- pkgdesc = Qualitative data analysis for text, images, audio, video. Cross platform. Python 3.6 or newer and PyQt5.
- pkgver = 2.9
- pkgrel = 2
+ pkgdesc = Qualitative data analysis for text, images, audio, video. Cross platform. Python 3.6 or newer and PyQt6.
+ pkgver = 3.0
+ pkgrel = 1
url = https://github.com/ccbogel/QualCoder
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-pyqt5
+ depends = python-pyqt6
depends = python-lxml
depends = python-pillow
depends = python-ebooklib
@@ -14,9 +14,11 @@ pkgbase = qualcoder
depends = python-ply
depends = python-chardet
depends = python-openpyxl
+ depends = python-pandas
+ depends = python-plotly
depends = python-pydub
depends = python-speechrecognition
- source = https://github.com/ccbogel/QualCoder/archive/refs/tags/2.9.tar.gz
+ source = https://github.com/ccbogel/QualCoder/archive/refs/tags/3.0.tar.gz
sha256sums = SKIP
pkgname = qualcoder
diff --git a/PKGBUILD b/PKGBUILD
index 7f4574e36e6f..b6d4867afaa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=qualcoder
_pkgname=QualCoder
-pkgver=2.9
-pkgrel=2
-pkgdesc="Qualitative data analysis for text, images, audio, video. Cross platform. Python 3.6 or newer and PyQt5."
+pkgver=3.0
+pkgrel=1
+pkgdesc="Qualitative data analysis for text, images, audio, video. Cross platform. Python 3.6 or newer and PyQt6."
arch=('any')
url='https://github.com/ccbogel/QualCoder'
license=('MIT')
-depends=('python-pyqt5'
+depends=('python-pyqt6'
'python-lxml'
'python-pillow'
'python-ebooklib'
@@ -18,11 +18,13 @@ depends=('python-pyqt5'
'python-ply'
'python-chardet'
'python-openpyxl'
+ 'python-pandas'
+ 'python-plotly'
'python-pydub'
'python-speechrecognition')
makedepends=('python-setuptools')
_name=${pkgname#python-}
-source=("https://github.com/ccbogel/QualCoder/archive/refs/tags/2.9.tar.gz")
+source=("https://github.com/ccbogel/QualCoder/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {