summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2021-07-18 10:27:33 +0300
committerAnton Kudelin2021-07-18 10:27:33 +0300
commita9e109c18b8d9d24ec87626cd4bd5cdcfdc6e906 (patch)
tree67a9a64b7e6637fa09e62d461f48cdd7cf055f06
parentb64619591a6a897ec1115d419d99166d5719285c (diff)
downloadaur-a9e109c18b8d9d24ec87626cd4bd5cdcfdc6e906.tar.gz
updpkg: 6.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ecc1226d7ec..002e4e040b7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = quantum-espresso
pkgdesc = A suite of codes for electronic-structure calculations and modeling
- pkgver = 6.6
- pkgrel = 2
+ pkgver = 6.7
+ pkgrel = 1
url = https://www.quantum-espresso.org/
arch = x86_64
license = GPL2
@@ -10,8 +10,8 @@ pkgbase = quantum-espresso
depends = libxc
depends = elpa
depends = fftw
- source = https://gitlab.com/QEF/q-e/-/archive/qe-6.6/q-e-qe-6.6.tar.bz2
- sha256sums = 20384d86e963950c446e7f5b4703f84db755a8e630a7ad6a53b567b74f324b02
+ options = !buildflags
+ source = https://gitlab.com/QEF/q-e/-/archive/qe-6.7MaX-Release/q-e-qe-6.7MaX-Release.tar.bz2
+ sha256sums = c67429353d49142b675ba6deefbde9594159518bf331aac187ee45a46d02734d
pkgname = quantum-espresso
-
diff --git a/PKGBUILD b/PKGBUILD
index 62e54d511bc5..1950c7cfb1c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
pkgname=quantum-espresso
-pkgver=6.6
-pkgrel=2
+pkgver=6.7
+pkgrel=1
pkgdesc="A suite of codes for electronic-structure calculations and modeling"
arch=("x86_64")
url="https://www.quantum-espresso.org/"
@@ -10,12 +10,13 @@ license=('GPL2')
depends=('libxc' 'elpa' 'fftw')
makedepends=('gcc-fortran')
checkdepends=('python')
-source=("https://gitlab.com/QEF/q-e/-/archive/qe-$pkgver/q-e-qe-$pkgver.tar.bz2")
-sha256sums=('20384d86e963950c446e7f5b4703f84db755a8e630a7ad6a53b567b74f324b02')
+source=("https://gitlab.com/QEF/q-e/-/archive/qe-${pkgver}MaX-Release/q-e-qe-${pkgver}MaX-Release.tar.bz2")
+sha256sums=('c67429353d49142b675ba6deefbde9594159518bf331aac187ee45a46d02734d')
+options=(!buildflags)
prepare() {
export _elpaver=$( ls /usr/include | grep elpa | sed 's/elpa_openmp-//g' )
- mv "$srcdir/q-e-qe-$pkgver" "$srcdir/$pkgname-$pkgver"
+ mv "$srcdir/q-e-qe-${pkgver}MaX-Release" "$srcdir/$pkgname-$pkgver"
}
build() {
@@ -35,7 +36,7 @@ build() {
check() {
cd "$srcdir/$pkgname-$pkgver/test-suite"
- rm pw_pawatom/paw-vcbfgs.in
+ rm pw_pawatom/paw-vcbfgs.in pw_relax/relax-extfor.in
make run-tests-pw-serial OMP_NUM_THREADS=4
}