summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSushil Khatri2022-07-01 22:37:35 +0545
committerSushil Khatri2022-07-01 22:37:35 +0545
commitcb152ea3412bc3381b57950e424b77017dace828 (patch)
treef6250b912d22417fb56739d3f7b78eeaa45bc0cd
parenta9e109c18b8d9d24ec87626cd4bd5cdcfdc6e906 (diff)
downloadaur-cb152ea3412bc3381b57950e424b77017dace828.tar.gz
7.1 first trial
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
2 files changed, 10 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 002e4e040b7d..af5eb75083a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = quantum-espresso
pkgdesc = A suite of codes for electronic-structure calculations and modeling
- pkgver = 6.7
+ pkgver = 7.1
pkgrel = 1
url = https://www.quantum-espresso.org/
arch = x86_64
license = GPL2
checkdepends = python
makedepends = gcc-fortran
- depends = libxc
- depends = elpa
- depends = fftw
- options = !buildflags
- source = https://gitlab.com/QEF/q-e/-/archive/qe-6.7MaX-Release/q-e-qe-6.7MaX-Release.tar.bz2
+ depends = openmpi
+ source = https://gitlab.com/QEF/q-e/-/archive/qe-7.1/q-e-qe-7.1.tar.gz
sha256sums = c67429353d49142b675ba6deefbde9594159518bf331aac187ee45a46d02734d
pkgname = quantum-espresso
diff --git a/PKGBUILD b/PKGBUILD
index 1950c7cfb1c6..73b8c1005795 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,23 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
-
+# Maintainer: Sushil Khatri <esinkei @ tuta dot io>
+# Contributor: Anton Kudelin <kudelin at protonmail dot com>
pkgname=quantum-espresso
-pkgver=6.7
+pkgver=7.1
pkgrel=1
pkgdesc="A suite of codes for electronic-structure calculations and modeling"
arch=("x86_64")
url="https://www.quantum-espresso.org/"
license=('GPL2')
-depends=('libxc' 'elpa' 'fftw')
+depends=('openmpi')
makedepends=('gcc-fortran')
checkdepends=('python')
-source=("https://gitlab.com/QEF/q-e/-/archive/qe-${pkgver}MaX-Release/q-e-qe-${pkgver}MaX-Release.tar.bz2")
+source=("https://gitlab.com/QEF/q-e/-/archive/qe-${pkgver}/q-e-qe-${pkgver}.tar.gz")
sha256sums=('c67429353d49142b675ba6deefbde9594159518bf331aac187ee45a46d02734d')
-options=(!buildflags)
-prepare() {
- export _elpaver=$( ls /usr/include | grep elpa | sed 's/elpa_openmp-//g' )
- mv "$srcdir/q-e-qe-${pkgver}MaX-Release" "$srcdir/$pkgname-$pkgver"
-}
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --enable-openmp \
- --with-libxc \
- --with-elpa-version=2019 \
- --with-elpa-include=/usr/include/elpa_openmp-$_elpaver/modules \
- --with-elpa-lib="-lelpa_openmp" \
- BLAS_LIBS='-lblas' \
- LAPACK_LIBS='-llapack' \
- SCALAPACK_LIBS='-lscalapack' \
- FFT_LIBS='-lfftw3 -lfftw3_threads'
- make all MANUAL_DFLAGS='-D__FFTW3' LD_LIBS='-lgomp'
- make -j1 epw MANUAL_DFLAGS='-D__FFTW3' LD_LIBS='-lgomp'
-}
-
-check() {
- cd "$srcdir/$pkgname-$pkgver/test-suite"
- rm pw_pawatom/paw-vcbfgs.in pw_relax/relax-extfor.in
- make run-tests-pw-serial OMP_NUM_THREADS=4
+ ./configure
+ make all
}
package() {