summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-08 09:40:03 +0800
committerzxp198210052023-10-08 09:40:03 +0800
commit2638bc8a76dc29bb5ee74680b049e5fc9dc376a7 (patch)
tree7d3521ce4ffc9a538483d01aba123f81ee20822a
parentc79d72df06e26d76fc7e3c772814043c7830237f (diff)
downloadaur-2638bc8a76dc29bb5ee74680b049e5fc9dc376a7.tar.gz
update to 3.2.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33fc9b8c5c0c..eda20bd5d6c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = quark-player-bin
pkgdesc = An Electron based Web Video Services Player, supporting Netflix, Youtube, Twitch, Floatplane, Hulu and More!
- pkgver = 3.2.4
+ pkgver = 3.2.5
pkgrel = 1
url = https://github.com/Alex313031/quark-player
arch = x86_64
@@ -29,11 +29,11 @@ pkgbase = quark-player-bin
depends = libcups
depends = libxcomposite
depends = alsa-lib
- provides = quark-player=3.2.4
+ provides = quark-player=3.2.5
conflicts = quark-player
- source = quark-player-3.2.4.deb::https://github.com/Alex313031/quark-player/releases/download/v3.2.4/quark-player_3.2.4_amd64.deb
- source = LICENSE.md::https://raw.githubusercontent.com/Alex313031/quark-player/v3.2.4/LICENSE.md
- sha256sums = 411128dfe791f161681eb5a2ddef52610b5b763bba5258de9ae46b0cd2579a92
+ source = quark-player-3.2.5.deb::https://github.com/Alex313031/quark-player/releases/download/v3.2.5/quark-player_3.2.5_amd64.deb
+ source = LICENSE.md::https://raw.githubusercontent.com/Alex313031/quark-player/v3.2.5/LICENSE.md
+ sha256sums = 2147ecb0de939130eb53f2619bc2747e47537814e2d016da172db97aeb1e978b
sha256sums = f60c2918d56a97a03b92e13e9fc479e81db309476ec26f7c8c0df82007612117
pkgname = quark-player-bin
diff --git a/PKGBUILD b/PKGBUILD
index 157d4717036e..ff74f5bc7cbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=quark-player-bin
_pkgname="Quark Player"
-pkgver=3.2.4
+pkgver=3.2.5
pkgrel=1
pkgdesc="An Electron based Web Video Services Player, supporting Netflix, Youtube, Twitch, Floatplane, Hulu and More!"
arch=('x86_64')
@@ -13,9 +13,9 @@ depends=('gtk3' 'pango' 'expat' 'mesa' 'libdrm' 'libxcb' 'glibc' 'libxfixes' 'db
'cairo' 'libxrandr' 'at-spi2-core' 'glib2' 'libxdamage' 'gcc-libs' 'libx11' 'libxext' 'nspr' 'libcups' 'libxcomposite' 'alsa-lib')
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"LICENSE.md::https://raw.githubusercontent.com/Alex313031/quark-player/v${pkgver}/LICENSE.md")
-sha256sums=('411128dfe791f161681eb5a2ddef52610b5b763bba5258de9ae46b0cd2579a92'
+sha256sums=('2147ecb0de939130eb53f2619bc2747e47537814e2d016da172db97aeb1e978b'
'f60c2918d56a97a03b92e13e9fc479e81db309476ec26f7c8c0df82007612117')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|${pkgname%-bin} --no-sandbox %U|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}