summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Cass2023-05-31 15:33:23 -0700
committerJosh Cass2023-05-31 15:52:29 -0700
commitcb8d181e0d3ff07c43604cb4454ddbb41318ad2e (patch)
tree118d39f33fdd4d22466eac489d0f27730b817217
downloadaur-cb8d181e0d3ff07c43604cb4454ddbb41318ad2e.tar.gz
add pkgbuild
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cadc50e76af6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = quarkuscli-bin
+ pkgdesc = Create projects, manage extensions and perform build and development tasks for Quarkus, the Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM.
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://github.com/quarkusio/quarkus
+ arch = x86_64
+ license = Apache
+ provides = quarkus
+ source_x86_64 = https://github.com/quarkusio/quarkus/releases/download/3.1.0.Final/quarkus-cli-3.1.0.Final.tar.gz
+ sha256sums_x86_64 = 528228677ba93c3d57ee60acfd3bee4153bd5d5c939c34a3e315763a21d458e8
+
+pkgname = quarkuscli-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93f7e909a49d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Josh Cass <aur@darkstar.mozmail.com>
+pkgname=quarkuscli-bin
+pkgver=3.1.0
+pkgrel=1
+pkgdesc='Create projects, manage extensions and perform build and development tasks for Quarkus, the Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM.'
+url='https://github.com/quarkusio/quarkus'
+source_x86_64=("https://github.com/quarkusio/quarkus/releases/download/$pkgver.Final/quarkus-cli-$pkgver.Final.tar.gz")
+arch=('x86_64')
+license=('Apache')
+depends=()
+optdepends=()
+conflicts=()
+provides=('quarkus')
+sha256sums_x86_64=('528228677ba93c3d57ee60acfd3bee4153bd5d5c939c34a3e315763a21d458e8')
+
+package() {
+ cp -R "${srcdir}/quarkus-cli-$pkgver.Final/bin" "${pkgdir}/usr"
+ cp -R "${srcdir}/quarkus-cli-$pkgver.Final/lib" "${pkgdir}/usr"
+}